Axis Camera err.

Hey guys, I’m having troubles getting my camera to give me a live feed. I have the latest image on the cRIO and I have run the Setup Axis Camera tool successfully a few times. I have tried changing it from Ethernet port 2 on the cRIO to port 2 on the router and changed the code in the to reflect what i set the camera to do with the camera tool.
Most of the time the camera lens has the orange light around it, but sometimes it has turned green and I still haven’t received a video feed.
Attached are; 1. the error list generated through the driver station (before enabling) and 2. a screen cap of running the in labview with Highlight Execution turned on.

camera err DS.txt (639 Bytes)

camera err DS.txt (639 Bytes)

Try starting from scratch, it looks like you’ve chewed up the default code a bit.

  • Rerun the camera setup utility to get the settings right and verify the settings by successfully browsing to the camera at 10.xx.yy.11
  • Make sure you have a green ring before expecting any picture
  • Connect the camera to the DLink, not the cRIO
  • Create a new default robot project, and don’t make any changes to it.
  • Download the project of course.
  • Fireup the default Dashboard
    *]Verify your Classmate IP address and netmask
    The default code and settings expect the camera to be connected via the robot DLink with an IP address of

Thanks for the quick response, I’ll start from scratch and post the result. It will be 4hr+ before i can get my hands on the robot.

I just attempted to start from scratch. I re-imaged the crio, ran the axis camera tool, and made a brand new frc project (all of which were successful). After all that I am getting a very similar error log from the driver station and the camera ALWAYS has an orange light.
Attached is the latest error dump from the DS.

camera err 1.17.txt (600 Bytes)

camera err 1.17.txt (600 Bytes)

First of all, which model camera are you using? Do you have the Axis 206 or m1011? We’ve run into some similar problems using the older (206) camera. I’m not sure if the Axis Camera configuration tool provided by FIRST is model dependant, but we also ran into trouble when using the tool. Once we set the camera settings manually, everything worked normally. Here’s our process, in case it helps:

[li]Reset the camera (hold the button on the back and power up at the same time)[/li][li]Change your computer’s IP to (the last number can be anything except 90)[/li][li]Plug the camera directly into your computer’s ethernet port, using a crossover cable[/li][li]Open you web browser of choice, and navigate to[/li][LIST=1]
[li]You will be prompted for a password: “pass” [/li][li]On the left side on the screen, go to the “Users” page (or some derivation of that)[/li][li]Change the password for the admin account to “admin”[/li][li]Create a new user account, username “FRC”, password “FRC”[/li][li]Go to the “Network Settings” (or some derivation thereof) page and change the camera’s IP settings to the following:[/li][ul]
[li]Camera IP: (where is your team number; mine is 11.24)[/li][li]Subnet mast:[/li][li]No gateway[/li][/ul]
[li]Hit save.[/li][/ol]
[li]Change your computer IP to (or any address not already in use)[/li][li]Plug the camera into the dlink bridge using a regular (un-crosssedover) cable and plug your computer into the dlink with another regular ethernet cable[/li][li]Point your web browser to, and enter the proper login credentials (that you set a few steps above)[/li][li]If you see a live feed, you’ve done it right![/li][/LIST]

This document may also be of use (note: it’s last year’s document, so a little incomplete, but the settings there are correct. It will take you through about my step 4.3.

This process worked for us (I just did it about 30 minutes ago), and it’s probably not the best way to solve the problem, but it’ll work (albeit require some more work on your part). YMMV.

I had a similar problem with the Axis 206. Manually configuring the camera did the trick. Thanks for the help!

thanks for the helpful tips. Our camera finally died the other day. it was the older model 206. merely bumping the camera/wires caused the camera to power cycle. I have checked that everything is electrically sound. The team has placed an order for the newer model m1011 and should expect that within a week.

Thanks again for the replies.

If bumping the wires causes it to reboot, it may well be the barrel connector and not the camera. I’m not going to discourage getting another camera, but if you look around at other electronics devices, you can likely find a connector that works. Also, in the kit when they included the camera, they gave out two power cables, one coaxial and one lamp-cord style. Perhaps you can move to the other cable.

Greg McKaskle