Axis Camera M1011 Wireless Setup

My team has never used a camera before, I am the head & only programmer (and president of the club). I am sincerely struggling with getting the Axis Camera to work, I think the biggest problem is that I can’t quite wrap my head around how it works. Here are all the issues…

So I have the camera spliced and plugged into the VRM 5V and it seems to be getting power. The power light on the back is on but not the network light or the indicator ring around the camera lens. The ethernet port in the cam is connected to the radio, and the radio is connected to the RoboRIO.

I configured my radio. I connect my computer to my Robot WiFi (2872) and navigate to the Axis Camera Setup Tool in the LabVIEW 2016 folder in National Instruments in my Program Files (x86) etc. It can’t find the camera at all! I have a hazy memory of it working the first time I tried to set up the camera in the beginning of the year, but a lot has changed since then and we updated our NI software etc.

I code in Java and I initialized the CameraServer simply by pasting the example code over. It used to work. I tried changing my local wireless IP to and navigating to in my browser and nothing happened. Any help is welcome. Thanks so much, I’m really frustrated and lost.

The Axis Camera Setup Tool expects the Axis camera to be connected directly to the PC’s Ethernet port.

It says in the setup tool directions:

  1. Connect the Axis camera to the radio. The DHCP Server on the radio should set the IP Address of the Axis camera. This can take a few minutes, and is complete when the Camera found LED turns on and shows an IP Address.

What does this mean?

Connect the camera and laptop to a hub or switch. The 2 ports on the back of the radio should work.

Program the camera, and give it a fixed IP address of 10.TE.AM.11

Setup the camera per the FRC instructions (keep the fixed IP address)

Confirm you can stream a video to your laptop.

Disconnect the Driver Station, and connect via wifi

Can you still stream a video?

I fear this indicates a hardware problem with the camera. In general, the light around the lens should always come on in amber within about 15 seconds after power is applied, and go green within 30, even if no network cable is attached. Try it this way.

Try powering the camera from its own AC power supply to rule out power supply issues. You can also reset the camera by holding down its reset button before applying power. Hold it down until the lens ring lights up. If it doesn’t come on at all it didn’t work.

If the lens ring status light won’t light with no network connection, it’s a lower level problem not a network or configuration problem.

I hope I’m wrong, as I have one in this condition I’d really like to fix.

This was a burnt camera.
It had apparently been connected to 12v at some point.

Another camera worked fine when swapped in.