Axis Camera M1013 Issues

Hey guys!

This week I’ve begun looking into camera setup. I pulled out our camera box and found an Axis M1011 and an Axis M1013. My preference is the M1013, since it has a comparably wider viewing angle than the M1011. Unfortunately I’m having terrible connection issues with the M1013. I plug it into the router, and the router into the computer, and I open the axis camera config. Of the 5-6 times I’ve done this, 3-4 of those times the camera was never found. At least twice, the camera has been found, and I’ve pushed ‘apply’. However when I login to the web viewer the camera doesn’t display an image. I’m able to change settings, but I can’t see the feed. It gives a warning about too many users viewing, or changing the browser config. I’ve changed the config, and also tried all the little drop down options on the live feed page. I’ve tried IE and Chrome. Weirdest thing is that I’ve successfully configured the M1011, and can view its feed just fine.

Has anyone else experienced such issues? Or is this likely an issue specific to my camera? Any thoughts on troubleshooting?



We have two M1013 cameras for our robot. We do not have any issue with these cameras. I have even had three people logged in and looking at the video feed at one time.

How do you have this camera connected? Are yo connecting any other devices? Are you using the Dashboard or vision on the RoboRio to access the camera?

This is where I would start. It sounds like you have some things access these camera that you are unaware of. I would try to isolate code and see if the problem goes away.


I haven’t gotten to the code stage yet. Just configuring. That’s where I’m experiencing issues. I plug the camera into the router, and the router into the computer, and I open the axis camera config. When the camera does connect, which it doesn’t always do, I can’t get the feed to display.

Are you accessing the camera through a web browser? What address are you using? How do you have your RoboRio configured? Are you using the DNS addresses or the static IP addresses? Is anyone else logged into the RoboRio through the wireless connection?

Yes, I have been attempting to access the camera in the web browser. I’ve been using the IP provided when I use the Axis Camera Setup Utility (usually some variation on The RoboRio is imaged per the guidelines set up in the WPI documentation. However, I should again stress that I’m not connected to the RoboRio at all. I have the M1013 and the laptop I’m using plugged into the router, which is being powered by the VRM. The whole thing is still isolated from the RoboRio.

First have you seen this?

I am assuming so but just wanted to make sure.

So are you plugged directly into the computer? If so did you set up and IP address for the Network to talk to this sub net?

If not what other peripherals are you using? Make sure that the network you are connecting to is the same basic structure as the IP address on the camera.

I was wondering if you have used other browsers.

Greg McKaskle

Just Chrome and IE so far.

@aeastet I have been following along with that WPI page. I haven’t tried a direct connection between camera and computer, just the camera to router and router to computer.

We’re getting the same issue here. Strange part is, our Axis camera has been working fine up until the other day. We were getting a feed to SmartDashboard just fine at the practice field on Saturday. Robot was shut down over night, then on Sunday at the practice field: no feed and that same “too many users” error you are seeing when we look at the config page the camera serves.

Wish I had a solution for you, but at least this means you aren’t the only one. I’ve got some things to try this week and will keep you posted.

One of our other mentors dug deep this weekend to try to identify the issue, including a factory reset, updated firmware, and powering off a nice clean benchtop supply. He took it apart and couldn’t find any obvious problems.

His opinion is that they are totally pooched. He’s opened a ticket with AXIS support, but not confident anything will come of it.

We picked up a $30 USB cam to try out this week.

We had an axis camera (m1011 or m1013) that was working on our practice bot, and then seemed to just die whilst sitting in our closet for about a week. The front LED does not turn on, but the back power one does. I think our issue may be a bit different than yours, as ours does not show up at all on the router’s list of active clients, nor can we communicate with it in any way. The back network LED does not turn on.