Bad Router

Hello again,

Whenever we hook the computer wirelessly or directly to the router we have MAJOR lag issues. The robot does things we don’t tell it to do…

But, whenever plugged into the cRIO, we have no issues… The team feels that we have a bad router… anyone else have this issue? If so, how did you get around it?


Check your channel use. Something else may be on the same channel. I don’t know how to change the channel, though…

We had this issue too… is your radio to close to your motors as in within a foot?

If you log onto the dlink (go to, you can click on “manually configure wireless settings” and select a different channel (or maybe auto channel scan?). That might fix it… or it could just be the solar flares again, they caused us some intermittent problems recently… :rolleyes:

We had a similar problem: see this thread for our solution.

Long story short, there was a 2 second lag between the driver station and robot access point.
So we upgraded the firmware (see above thread for link), eliminated conflicting devices (the root cause of the lag), and set/configured the dlink to bridge mode so that it connected to another router (don’t know how much this helped though).

Good luck!

We had figured out that the router, when placed a distance away from the DC converter, would not drop out for more than a few milliseconds. I can assume those dropouts are simply bad packets, and the communication lag was caused by an interference from the DC converter.