BASIC error

Please respond ASAP.
I just downloaded the default code into the basic stamp and it say “BASIC ERROR”

It worked fine last night when I tried it but i dunno what’s wrong. I haven’t changed any thing, i tried downloading it again and loading it, but doesn’t work

HELP ME~~~!:o

You probably have it working by now, but…

I found that the program will not run sometimes if the serial cable is still plugged in to the PROGRAM port. We disconnect the cable as necessary. After you disconnect the cable, press RESET on the RC.

Your default program may have been accidentally changed and saved to disk. Download the program again from and try again.

If you still have trouble, repost to this thread.

Maybe you didn’t save it or you’re loading a different one so it’s not the same as last night. If you can’t get it to work post the code and someone will help you I’m sure.

It’s been my experience that everytime I load a new program I need to hit the Robot Reset button to re-initialize the processor.

Hang in there Punar. It’ll all make sense the day after shipping.

After downloading a new program to the controller, you need to reset your robot controller (pushing the “robot reset” button will do, as well as simply turning the robot off then back on again).
Also, One of the programmers on our team was using a laptop with Windows 2000 to program the robot. We had to disconnect the cable from the program port when we wanted to run the new program. On a Windows 98/95 system, disconnecting hasn’t been necessary. (I don’t know what would happen if we tried Windows Me, or XP)