BAUD

We are not getting any signal from the camera at all. Everything is hooked up right and all but we have no clue why there is no signal. Any suggestions?

did you take the lens cap off :smiley:

are you trying it “on the bench” or on the robot

Did you download the code yesterday?

-Kevin

We have the code and both versions of it. We are use the RB and not the GUI but we do have all the color codes needed to find the light from the GUI. We have that data in the program and have dumpped it onto the RC. Everything is hooked up right but were getting a constant “Searching” in the data window. It is not hooked up to a robot but power is not a problem.

What happens if you just load the camera.hex file included in the zip archive? The default calibration values should work out-of-the-box with the FIRST green light.

-Kevin

The signal problem was fixed by activating the GUI before using the RC… have no clue why it worked but it did.

We ran into another problem but solved it. The camera would move away from the center of the light. We fiqure this happened because we used flipped the camera around to fit a rightside up picture grab on the GUI… this does not correspond well with the code you will have to change signs of the servos in the servo tracking file to the inverse of what they are.

Did you still have the TTL cable plugged into the RC at the time? I think the first one to talk to the camera is the one that gets the info.

to be totally honest i have no clue if that did make the problem go away or not but after we reloaded the GUI it worked with the RC so… yea