Big problem! Need your help

Okay so i posted this last week and didnt get the problem fixed so i thought id try again.

Our robot this year was running up until last week. While driving someone had hit the autonomous switch on the Driver station and the joysticks stopped working. The DS says battery is 12.00v and that it is connected. The cRIO is getting button signals to it, but the motors don’t do anything when you move the joystics. We hav tested the joysticks and they work on computers, but the jaguars stay a flashing orange/yellow.

We have tried replacing the wiring to it all, the digital sidecar, the jaguars, and nothing is working. The DS is enabled and in teleop.

Any and all help would be great.

The first question I would have is what does the driver station say as far as what mode you are in? Does it say Teleop or Autonomous?

Maybe the switch that controls the two modes is stuck in the autonomous mode.

Its in Teleop and we’ve tried going back and forth got nothing

Have you tried to get in contact with other local teams for hands-on help? I think 842 has had the control system for a while and is pretty familiar with it, and I know they love to help other teams

Have you checked the “Getting Started Guide” for the Jaguars? On page 2 there is an LED Status table. According to the one we’re looking at right now under fault conditions
Slow flashing yellow indicate Loss of servo link
Slow flashing red indicate general fault condition
Flashing red and yellow indicates calibration mode failure
:ahh:

Look at the following link for the full guide:

http://www.luminarymicro.com/jaguar

Best of luck in getting them fixed!

Team 2582

Have you verify the 9-pin enable/disbale switch is securely connected to the DS and is enabled.

-pete

there are many faults to our dashboard heres some:
• Hot plugging joysticks is not supported. If you plug in a joystick after the DS has already booted,
it will not be recognized. The workaround is to always have joysticks plugged in.
• The DS only supports joysticks that use the standard HID interface. This means that if a joystick
requires special drivers on windows, it won’t work with the DS. Unfortunately, this means the
XBOX 360 controller won’t work.
• There is no API for displaying data on the DS LCD (like the UserMode byte from previous
years). This is planned, but not implemented yet.
• Occasionally the DS will send bad joystick data before the joystick has been moved the first
time. The workaround is to always make sure the robot is disabled when first starting up, and
move the joysticks before enabling for the first time. (This problem will be fixed soon!)
• When a joystick is unplugged, the DS continues sending the last valid joystick value. The
workaround is to not unplug joysticks while running.
• Occasionally, communication will lag by about 2 seconds. The workaround is to unplug any
Ethernet cable for a second, then plug it back in.
• Occasionally, communication will stop between the DS and the cRIO. One way to notice this the
robot will stay disabled when you enable. The battery voltage on the DS display will also not
update. The workaround is to unplug power to the DS and then let it reboot.

So after reading the Getting started pdf i realized that there is no servo connection, so i replaced the pwms and tried it all again and still nothing worked.

After you disconnected everything did you power everything completely down and then back up again in the correct order?

Did you try to reload the programming?

Here’s a few things i would try to diagnose the problem - simply knowing that “it doesn’t work” doesn’t help narrow down the problem to a scope where you can find a solution :slight_smile:

  1. Download the SimpleRobot example code. This takes all of the “risk” of your own customized code out of the picture.
  2. Run the autonomous mode of SimpleRobot. This takes the joystick inputs out of the equation. If the motors don’t spin, then the problem is probably somewhere in the wiring. If they do spin, go on to the next step.
  3. Run the teleoperated mode of SimpleRobot. This lets you see the “full path” - you see everything from the joystick inputs to motors moving.
  4. Download your own code again, and test it out.

So, depending on where you fail above, you’ll know where the problem is. Fail on step 2? check the wiring. Fail on step 3? Check the DS and the joysticks. Fail on step 4? give the programmers some more Mountain Dew, cause they’re gonna be there debugging for a long time…

we talked to them about it and they said they couldnt really find the problem unless they looked at it so we are heading over there on friday but we wanted to try and get a head start on it before hand

We never put any code into the robot but we try it and see if the base code maybe got corrupted, if thats even possible