Black Jaguars bricked after 2CAN update


#1

We just tried to connect our Jaguars through a CAN chain connected to a 2CAN 2.0, running latest firmware. We managed to get into the Web Dashboard and 2 out of 4 nodes were recognized.

When we tried to update each Jaguar’s firmware to latest through the “Node Update” section, the Jaguars bricked and now they don’t output any light through the indicator LED. We’ve also used the latest *.bin file for the task, of course.

Also, after we updated one Jaguar, the 2CAN’s indicator LED turned from a steady green to a fast red strobe.

How can we restore the Jaguars, if it’s possible at all?


#2

I have come across this problem myself, and should be reversible. The bad part is, if you do not already have a serial to CAN adapter handy, this will be the time to make one.

Included in the Driver Station software and Utility Updates, there is a program called BDC-Comm. Start that up with only one of the bricked Jaguars plugged into the CAN port (For serial communications, you must plug your serial adapter into the left port of the Jaguar. Remember to terminate the other port.) Once BDC-Comm has started, there should be a menu item somewhere along the lines of “Recover Firmware” (IIRC, it’s in the File menu). Select your firmware bin and flash it using the recovery feature. This should bring your Jaguar back to its normal life.

The fast red strobe would indicate a CAN error. Make sure you have your termination resistor in place for the network to run correctly.


#3

An error box comes up saying “Unable to contact the boot loader!” upon starting the Recover Device process
Reoccures no matter which Jaguar is connected to the PC


#4

Have you proven that your serial CAN adapter works on a known good jaguar?


#5

Well it did work just a few days ago, and on previous seasons. I’m almost certain it’s not the cable. What else can I do?


#6

Does anyone have another suggestion, please?


#7

Wires do break on occasion.

What else can I do?

You can verify that your serial CAN adapter works on a known good jaguar.


#8

We hit something similar today. In our case, we had issues with Windows Firewall, and new Internet Explorer, and Java; all three having an internal slap fight.

Our solution was to use the 2Can BDC-COM to do the update. It wasn’t completely smooth sailing. We got the same “Bootloader not found” - which accompanied an extinguishing of the Jaguar’s LED (PANIC!). Recover did not work in this case, with the Jaguar disappearing from visibility from the BDC-COM.

We cycled the power on the Jaguar, and re-attempted the flash, which worked. Almost all of our Jaguars required this second-attempt.

Important points:

  1. Make sure the 2CAN has the 2.29 firmware that comes with the 2CAN BDC-COM.
  2. Make sure that you terminate the Jaguar, and only have one on the 2CAN at a time.
  3. Don’t move the BDC-COM from the folder that has the required .dll’s (all are unzipped together).
  4. This method does need the firewall to allow the program, but it does not depend on any browser or Java working correctly.

– Len


#9

Thanks guys, we have a new problem now: we managed to connect a few jaguars through 2CAN successfully, but when we try to control the jaguars using actual LabVIEW code (motors’ mode is set to CAN jaguar and all, running example code), the jaguars’ LED remains in solid amber (disabled) even when we enable and pass a value to them.

We set the jaguars’ numbers through the web dashboard.


#10

Could you please post screenshots of your code? That way we can rule out anything being wrong there.


#11

Here it is

Begin.PNG
Teleop.PNG


Begin.PNG
Teleop.PNG


#12

Alright, your code looks good. When you look at your 2CAN, what color is the light? If it is anything but green, there is an error there.


#13

The 2CAN is Blinking Green and Web Dashboard says the 2CAN connection is successful.


#14

How are you adjusting the “Output” control in Teleop? Give a detailed description of exactly what we’d see you do as you try to make the motor go in one direction, then in the other.


#15

Currently we’re just trying to get the motors to move/respond. When we change the output control to 1 (and control mode is set to vBus in Begin.vi), the jaguars remain in solid amber state and do not seem to move the motors forward.


#16

When you test this, are you opening the “Robot Main.vi” and running it continuously, or are you actually building the code and setting it to run at startup?


#17

We just ran the “Robot Main.vi”, enabled the code and changed parameters at the “Teleop.vi”.


#18

Are there any messages in the Driver Station’s diagnostic window?


#19

I just checked the log files, we got error -44079, the firmware of the jaguar needs to be upgraded. But that returning us to the original post, how can we do it safely without bricking the Jags again?


#20

My preferred way is to update them one at a time using BDC-Comm. It reduces the chances of failure, and is using a native tool built specifically for these controllers.