BlackJaguar-101.bin failure


This is the first year our team is doing CAN and we’re using only black jags. We successfully connected to a single jag and read the configuration (fan speed, temp, voltage, etc). We went ahead and tried updating to firmware 101 and it failed. Tried another 10 times or so to recover with no luck. Tried again on a second jag and had the same failure. Both now seem to apear to be stuck on the bootloader and have no flashing status light. Any help reflashing or linking to a previous firmware version to try would be greatly appreciated.


Using usb to serial -> serial to CAN adapter (home made)-> black jag on left port -> bus terminal on black jag right port.

successfully read black jag config. using latest BDC_COMM 101

Oh, these things always seem to be finicky until a working setup is established. We had a similar issue amd had to recover a couple of them. I can’t remember the exact procedure, but you can somewhat reset the Jags by putting a paper clip like object through the hole on the right side of the Jag during power-up. Check how the light is flashing. It flashes slow yellow when in standby and quick yellow when there’s a problem and needs recovering. I think the lights alternated red and green when we reset them and then the light blinks slow yellow again. At this point we could recover and then update. Hope this helps.

If you still have problems, post what the lights are doing.

thanks for the response. Will try resetting using the user pin and post back when i meet with the team

Bdc _Comm has a recover device feature. It is under the file menu. Try it without the User mode button procedure described above, then try it with if it didn’t work.

I believe they tried to recover…and it didn’t work…

  • Bryce