BlackJaguar-99.bin issues

We tried to install the new version of the black jaguar firmware. (BlackJaguar-99.bin). We only tried this on last years black jags, but each time it bricked. We were able to only unbrick it using last years bdc-comm and BlackJaguar-92.bin. We tried for about 3hours to recover using 99.

Don’t know if anyone else is running into this situation, but may be wise to hold off until more information is discovered before flashing.

I didn’t experience this. I’ll try again on Monday with the files that come out of the utilities update installer. Does this only happen with black jags or does it affect tan jags as well with v99?

I have not tried to do the gray jag, since we needed the black one working to do this. Will try later today to flash a gray one.

Also found this document on the technical resources page Update Jaguar Firmware

It says that the new black jaguars come with firmware version 8161. It says that the others should be brought to at least that using qs-bdc24.bin. However i have not found any .bin files besides BlackJaguar-99.bin. Is this a miscommunication on the documents part and we are not doing can firmware updates using the same naming structure?

That is referring to the public released firmware. Bdc24 means brushed direct current 24volt. That’s the name of TI’s black jag development kit. Those instructions do not apply to the FRC firmware or use-case.

Joe

I wonder why FIRST is hosting it, and linking to it from the 2012 KOP Control system page. http://www.usfirst.org/roboticsprograms/frc/2012-kit-of-parts-control-system

On http://www.ti.com/jaguar, there is a new version of BDC-COMM (v100). I wonder if this helps. Per http://forums.usfirst.org/showthread.php?t=18461 there is also v100 firmware, but it’s identical to v99.

The document at that link is WAY out of date. It looks like an old version was accidentally uploaded. I will try and get the people at FIRST to upload the correct file, but in the mean time, this is what you need to know:

All Jaguars using CAN must have the latest FRC firmware installed for the 2012 season.
Jaguars that are using Servo PWM do not have to be updated from their default factory firmware. However, teams using PWM may wish to update their older Jaguars to the latest firmware in order to gain access to the new Automatic Ramp feature.

The required firmware version depends on the control mode you’re using:

  • Using CAN, you must
    use version 99 or higher of FRC Trusted firmware.
  • When using PWM, many firmware versions are acceptable:
  • - If you need the Automatic Ramp mode, you can use version 99 or greater FRC Trusted firmware, or you can use Non-FRC Trusted (factory) firmware 8161 or greater.
    - If you do not need the Automatic Ramp mode, you can use any version of FRC Trusted firmware or Non-FRC firmware.

A table in the updated document makes this easier to understand. Here is a quick rule of thumb:

If you are using CAN, you must update all of your Jaguars to at least version 99 of the FRC Trusted firmware. If you’re using PWM only, but you want the new Automatic Ramp mode on your old Jaguars, I recommend updating to FRC Trusted version 99 or higher anyway. Remember, any Jaguars recieved in the 2012 KOP have the new factory default firmware with the Automatic ramp mode, but are not loaded with the FRC Trusted firmware required for CAN.

-David

Just tried it again using the 100version and the same issue persists. Am still in the process of trying to recover it to a workable state.

Are you trying to update with v99 or v100 of bcd comm or are you using an older version?

Joe

I have tried using the ones that match each version. I have used the older one after several tries to put 92 back on them.

What is the exact behavior that makes you believe they are Bricked? Is there no flashing LED?

Correct no leds and messages failed to flash

The Jags is most likely just stuck in boot loader and not “Bricked”. Try re-downloading the BIN and make sure the BIN is for the correct version of the Jag (black or gray). If you try and load gray jag firmware onto a black jag the jag will stay in boot loader. Since there is no led state to indicate that the Jag is in boot loader, it appears as if it is bricked.

I am sure it is stuck. All versions ar downloaded new.

I just successfully loaded version 100 onto a black jag using a 2CAN. Have you tried updating the firmware using the 2CAN?

We do not own one.

I just flashed a 2012 Black Jag with version 100 bin. It took two attempts however. The first time I tried, the 2CAN status LED was RED indication an issue on the CAN side. The web dash confirmed this. Attempting to flash the jag resulted in failure (as expected) and the web dash indicated “no ack received” After power cycling the JAG only, the status LED turned orange, the Jag appeared in the web dash and version 100 was successfully uploaded.

You may have already tried this, power cycle the jag and re-attempt the flash.

I have flashed version 99 several times and never experienced this issue. I will try to reproduce it when I get home.

Ok, so tried to a tan/gray jaguar now daisy chained to one of the blacks. It was running 92 and tried to update to 100 it failed. I recovered it back to 92.

I am using a usb to serial adapter, but since I was able to do it to 92 and I can use adjust the controller with bdc-comm, I am assuming that is not an issue.

Thanks for everyone’s help I appreciate it.

Kyle

Our jaguars also stopped blinking when I tried to update the 99 firmware. I wasn’t able to recover to 92, 99, or 100 using their respective bdc-comm exe’s. Finally, I tried recovering it on another computer (the classmate) and that worked. (I happened to recover the the v100).