Bread Board Communication Hardships

Hey everyone.

So 4 people from my team, 2 mentors 2 programmers, participated in a Talon SRX workshop of sorts hosted by Stryke Force. We were excited by what we learned and wanted to test, and I, being the lead programmed, said we should build a Bread Board like the guy that showcased the Talon SRX did.

So tonight we did. It consists of a PDP, a RoboRIO from the Stronghold year (pretty sure) with an ADIS gyro hooked up through MXP, 2 Talon SRXs, one of which is connected to a CIM motor, no encoder, and the ever present RSL orange glowy fancy light.

I brought it home and have gone through 3 hours, 2 USB printer cables, an ethernet cable, and every internet resource I could get my hands on and I can’t communicate with the RoboRIO. The ping comes back failed unless I turn off my wifi, then it says server unreachable, even if the cable is unplugged, almost as if the RoboRIO doesn’t exist in the same plane of existance.

The RoboRIO imaging tool doesn’t see it either, neither the internet explorere web address through Is there something blatently wrong I’m doing? I’ve never done stuff like this before, the lead programmer last year was the one who worked with the web address, and never taught me. He left most of the labVIEW programming to me though.

I’ll send pictures of the bread board if at all possible, but bear with me please as this is my first post on a forums.


You seem to be at the stage where you would try a different computer because it isn’t working with USB, at least from looking through the troubleshooting whitepaper:

I have the similar experience of being in the role of programming mentor this year without much experience and I haven’t yet experienced the RoboRIO failing in this way, luckily. Searching here on CD I only came up with this thread ( where USB wasn’t connecting but I couldn’t tell you the steps they took to resolve it and would probably call NI first before trying.

Also, the Talon course sounds interesting. Is there some class note available somewhere?

Are lights lit on the Roborio? Which ones?

Is everything other than 12 volt power and your usb cable unplugged from the Roborio?

Are all your firewalls on your computer turned off?

Yes there are lights lit and they are the power and the RSL lights. When I power it up or hit the reset button the status light glows for a few seconds

Currently other than USB and power, CAN is plugged in, aswell as the RSL light, and the ADIS gyro connected through MXP. I just unplugged the ADIS, but won’t have time to test until later.

Now for firewalls, I did turn off windows firewall, is there anything else I need to turn off?

I used our team computer and my own computer. Both in the past have been able to connect to this years roboRIO.

They seemed to have to connect through the router somehow I think.

I saw the troubleshooting whitepaper and followed some of the steps but they didn’t seem to solve anything. I’m pretty sure it’s a problem not with both computers or on my end, I think there might be something wrong with the roboRIO or how we’ve connected it up.

The Talon course was very interesting. I didn’t know Talon SRX’s had PIDF built into them aswell as other things.

There is a slide deck and some other things but I don’t think I’m allowed to share them, because the group that took the class are a sort of beta test all the stuff that Stryke Force created. I do know that eventually they will release all of that when they have worked through all the kinks.

From the photo it looks like the roboRIO has an operating system running and is communicating with the Driver Station app., but there isn’t any user code running on the roboRIO.

I’d suggest disconnecting everything from the roboRIO except the power & USB, i.e., the ADI board, Ethernet, CAN.
Then start with the basics of trying to ping
Just look at the Diagnostics tab of the Driver Station app to see ping results.

Then try booting the roboRIO in Safe Mode and connecting to it with the roboRIO imaging Tool.

If you still can’t get it to work, consider revisiting Stryke Force to get some hands-on help.

I disconnected everything, evene at one point the RSL light and the exact same result. Command Prompt ping doesn’t work, the driver station doesn’t show anything.

I got it into safe mode, and the imaging tool can’t see it either. There is no problem with the cord because it works with my printer. So something must be wrong physically or with the software, unless I’m being a complete idiot and not seeing a specific piece that would make me go “uh duh”

I’ll see about emailing Stryke Force. We’re both kalamazoo teams so they’ll probably help and know something I don’t.