Bricked RoboRIO?

I suppose I’ll get right to the point here. The status light is continuously blinking, which according to various documentation, means that something has gone horribly wrong and to contact NI.

Now, as to how it got this bad. After unboxing the thing, I pulled up the tutorial on imaging it from LabVIEW and followed the instructions. Great. Imaged fine. Reading on, I see there’s an optional firmware update. I figure this would be a good idea as well, and attempted to update the firmware to the latest version. Something went wrong here, the exact message I don’t remember, but I believe if memory serves it was rather generic. I’m a little perplexed by this, and I see there’s no longer ANY firmware on it. Naturally, I try to upload the firmware again, this time it fails instantly. I decide the best course of action is to reformat and reimage it. It has errors actually uploading to image, and I start to get actually nervous. I try once more, same error. Having salvaged a seemingly bricked cRIO via safe mode before, I see the force safe mode option in the web dash (and I believe this is where I made a mistake)and check it. I reboot. I can no longer contact the RoboRIO at this point, via USB or ethernet. Rebooting doesn’t change anything, holding reset doesn’t change anything, I can’t contact it. At all. Which is where I am now.

What I believe is happening, now that I’ve read more documentation in a desperate attempt to salvage it, is that safe mode is actually managed by the firmware; you know, the thing that got messed up? And since I checked the force safe mode option without thinking, it’s now forced to boot into a mode it can’t access. So things are bad.

So, reason I’m posting this here, is to gather from you guys what the best course of action from here is. I’m trying to contact NI, but I’m honestly having a hard time finding my way through their support system. Anyone have any insight/help?

1 Like

From NI.com/FRC: “During the build season, you can call NI phone support at 866-511-6285 between 1:00 - 7:00 PM CST on weekdays”

Call in the next hour and a half and I have no doubt your roboRIO will be working by the end of the night.

This shows the LED status meaning:
http://wpilib.screenstepslive.com/s/4485/m/24166/l/144972-status-light-quick-reference

SO, what color are they blinking:

Power:
Green - Power is good
Amber - Brownout protection tripped, outputs disabled
Red - Power fault, check user rails for short circuit

Status:
On while the controller is booting, then should turn off
2 blinks - Software error, reimage roboRIO
3 blinks - Safe Mode, restart roboRIO, reimage if not resolved
4 blinks - Software crashed twice without rebooting, reboot roboRIO, reimage if not resolved, Constant flash or stays solid on - Unrecoverable error

You should be able to follow this procedure to recover the roborio to safe mode. Then re-flash the firmware:
http://wpilib.screenstepslive.com/s/4485/m/24193/l/287271-recovering-a-roborio-using-safe-mode

While attempting to boot to safe mode be sure you don’t have anything connected to the RS-232 (serial) port.

Thanks for the quick response. In my haste/panic, I completely forgot NI had a section of their site dedicated to FRC and was looking through their main support site. I’ll have to try tomorrow, though, since I posted this as my team was packing up shop. I’ll post back then.

Alas, but I’ve already tried this. No dice from safe mode, either.

There is a recovery mechanism for roboRIO - call NI when support opens and we can help walk you through it.

I was wondering if anyone knew anything about the lights on the PDP. Both of mine are off and i’m not sure if it’s just because I haven’t uploaded code to the roborio yet or is it telling me that I have a problem. I did the image but still need to set up the radio.:confused:

They show the CAN status. They will blink differently depending on status.

The User’s guides for the PDP, PCM and VRM are available on the Cross the Road Electronics website.

http://www.crosstheroadelectronics.com/control_system.html

Thanks. Will do.

For those of you who are in a crutch and need to get your roboRIO fixed, try this:

http://www.ni.com/white-paper/52593/en/

In particular, the last option (NI-Max) worked for me. It’s strange (for all the other options) that in order to fix the problem that you cannot access your system, you need to, paradoxically, access it from the web server.

Reformatting the device fixed the problem.

We had similar issues with one of our Rios this year. We contacted NI and went through their protocols. We were able to correct the problem for a short period of time, then it would happen again, which led us to believe it was a hardware issue.
We contacted Andy Mark and they replaced the unit immediately.