bricxcc error

I´m working with NQC using bricx Command Center 3.3. The firmware I´m using is firm0328.lgo. All in a Windows 2000. It is a RCX2.0.
When I want to download a program, I always have this error message:

Compile failed
no (or invalid) reply from RCX

The problem is that if the programme doesn´t have subs or tasks (a part from the main task), it works. But if it has subs and tasks, the RCX doesn´t download it.

Can you help me? Do I need to install anything else?

What version is the firmware on the RCX?

I took the firmware from Robotics invention System 2.0 de Lego Mindstorms.
I also tried with the one from LEGO Mindstorms SDK 2.5.
The file name is firm0328.lgo

I’m thinking its a windows 2000 permissions problem… I ran into a similar problem when trying to use it on my school’s computer… neither rcxcc nor the mindstorms software could see it. What type of IR tower are you using? I tried with the 9-pin serial one

XP doesn’t have this problem, neither does win98se

Also know that I’m fairly certain you can only use the mindstorms software or robolab to program the actual model to use. And from what I’ve seen, robolab is more powerfull :slight_smile:

I’m using an USB IR tower.
All right, I’ll try installing a VMwhere with a Win98SE.