Bridge configuration failed on OM5P-AN radio

Bridge configuration failed. Failed to change IP Address, please check for an adapter with the address 192.168.1.51 please ensure the bridge is connected to this computer and try again.

I keep recieving this error on a new Windows 10 64 bit machine. I have swapped Ethernet cables, I have swapped OM5P-AN radios. I re-flashed firmware successfully on one of the radios. I’ve rebooted several times after doing this, I disabled every firewall that I am aware of. I disabled the wifi first step in the process. I have played with DNS in IPv4. I cannot configure my OM5P radios. Any help?

I had the same issue! For me it’s probably because I forgot to image the radio using the Andymark instructions. Did you already do that? I’m still having trouble imaging the radio (it just keeps listening on the interface but it never seems to catch the radio), but I will let you know if that fixes the issue for me.

We’re having the same issue. Is there a separate set of Andymark instructions?

Getting “Started with the 2016 System” is hard to find if you do not already know to look for it. It used to easy to find on the old usfirst.org. But it is very hard to find on the new firstinspires.org site.

Getting Started with the 2016 Control System
https://wpilib.screenstepslive.com/s/4485/m/13503/c/86641

But what you are looking for is
https://wpilib.screenstepslive.com/s/4485/m/13503/l/144986-programming-your-radio-for-home-use

Hi All

I got the solution was able to log into the rio and upload code using Win 10. I am writing it up now and will paste it soon. It is 7PM MST right now. Should be done in 30 minutes. I am going to try for an attachment.

Hi All
I believe the cause was not having the “Allow other network users to control or disable the shared Internet connection.” checked for that network adapter. I put it together when I read an older post (can’t remember now) that said the radio needs to talk to the computer too. I reference it. I don’t a word processing software on this machine so I could not capture the screen prints for you. Thanks

Applies to Windows 10 (Mostly)
Download the latest FRC Radio Configuration Utility Installer from the$@#WPILib project File Releases.

Note: If you need to locate the program it is installed to C:\Program Files (x86)\FRC Radio Configuration Utility. For 32-bit machines the path is C:\Program Files\FRC Radio Configuration Utility\

Pin application to start menu and task bar.
Must Turn off Wifi on laptop before proceeding!
“Run as Administrator” by right clicking the icon on task bar.
Note: before you start the FRC Radio Configuration Utility, I identify the network interface name of the network adapter you will be plugging in. Single click on network icon in lower right part of the screen. When the available networks are presented to you, click on the “Network Settings” at the lower part the list. In the “Network Settings” screen click on the “Change Adapter Options” and that will take you to a Control Panel screen (Control Panel\Network and Internet\Network Connections). In there you should see all your network adapters on the box. Figure out the one you plugged in your radio. If there is a red X in the icons it means they are not active. Power up your radio and you will see it go active. That will be the name of the name of the network interface presented to you in the Radio Configuration Utility in the next step.
When the app opens you will be given a choice of network interfaces.

In “Network Interfaces” screen select “Ethernet” or the one you identified.
Connect 12v power cord and ethernet cable to the radio in 802.3af POE port
Wait for the power light to stay solid blue. Should see two solid blue lights, power and network.
Enter team # xxxx and password, and take all the defaults if that suits your needs Click the “Configure” button

You will see this Configuration progress screen, and it will say “successfully programmed”

When complete click the “OK” button.

**"You will see a message asking “Do you want to allow your PC to be discoverable by other PCs and devices on this network? We recommend allowing this on your home and work networks, but not public ones.” Click “Yes” **
I am not totally sure but I believe that In “Control Panel\Network and Internet\Network Connections” this is where this setting is changed and what fixed the problem. If you right click on your network adapter, and select the “sharing” tab you will see the choice to “Allow other network users to control or disable the shared Internet connection.” I believe that is what the dialog changes in the background. I see mine as checked an greyed out. I believe when I was having the problem it was unchecked. I believe the radio needs to talk to the network too, and without it checked it could not.

Also I left all my firewalls off too, but I don’t think that would have been a problem.

My mentor and I have been working on this all afternoon and still have not been able to get ours to work after following the directions above. We keep getting “Bridge configuration failed. IP address not changed. Please ensure the bridge is connected to this computer and try again”

It seems as if our computer isn’t even connecting to the bridge through ethernet. When we check our network connections ethernet still seems to be inactive although the bridge is powered and plugged in. We turned off all other connections, disabled firewall, and ran the utility as admin, and it still isn’t working.

Has anyone had a similar problem?

I could not get the force configuration utility to work. However, andymark instructions works. Make sure you connect to the radio after changing its IP address before you unplug it. Sometimes the settings Changes did not take until we did that.

Our team worked for several hours to use the Radio Configuration Utility last night and I thought I’d share our solution in case it helps other teams.

When we attempted the steps from the FRC documentation,
screenstepslive.com, we ran into the same problems described in this thread.

Our team member, Henry, discovered the solution which turned out to be two problems. The first is running the configuration tool as Admin. The second is properly disabling the wifi interface.

First, in order to conform to best security practices we have our driver station laptop set up with a admin account and an underprivileged user account that has the FRC software loaded onto it. However, the configuration utility must run as admin in order to change IP addresses. So we had to right click on the application and select “Run as administrator” when we launched the Radio Configuration Utility.

Second, we were getting the errors everyone else is talking about on this page that Henry discovered were caused by the wifi interface not being disabled properly. What makes this tricky is that the graphical icons in in the Windows 10 control panel are NOT intuitively clear.

The first preliminary step in the link above states, “Disable WiFi connections on your computer, as it may prevent the configuration utility from properly communicating with the bridge.” So, in the image below you would think the big red “X” next to the Bluetooth interface would mean that it is disabled. BUT THE RED “X” DOES NOT MEAN THE INTERFACE IS DISABLED.

In order for the interface to be disabled it has to be “greyed out” like you see the Wi-Fi interface in the image above after we solved the problem.

In order to get more clarity I think the command prompt is much clearer. Open a command prompt window and type

netsh interface show interface

and you will get a very clear report on the status each interface. The image below shows the Wi-Fi interface in its three possible states. You must be in ‘Admin State Disabled’ for the configuration utility to work.

So…in order to get to this state use the Windows GUI to start at the control panel and follow this link chain: Control Panel ->Network and Sharing Center -> Network Connections. Then right click on the Wi-Fi interface and make sure you select “Disable”. You can run the command prompt again to confirm the correct state.

After these steps we were able to upload the radio firmware and continue our build.

Good luck out there this year. I’m really looking forward to watching teams play Stronghold. This is gonna be great!

Thanks Coach Zac for the info. However, I had to go one step further and disable the Bluetooth adapter as well. I was able to flash the firmware and configure with ease.

I was just working on configuring this year’s radio and I ran into some trouble again. Even referring to last year’s solution, the Configuration Utility kept getting stuck at “Failed to configure bridge settings”.

After messing around a bit, I enabled IPv6 on the Ethernet Adapter, and that fixed the issue. It configured perfectly, though, I suppose it either does or it doesn’t.

Hope this helps,
Henry