Bridge Help!!!

I have been able to connect wireless to the robot using the new bridge in access point mode, but when i put it into bridge and connect the router to the laptop. The router will connect to the bridge. I looked settings on bridge mode and for some reason I can change the IP setting, but when i click on wireless tab in setup there are no settings. In the manual they said to change the wireless setting for the bridge mode, but cant see them.

Are there suppose to be settings other than the IP and if so what is wrong with our bridge then?

Note: the bridge’s firmware is at 1.21

I too had this problem. I reset the router, upgraded the firmware, reset again, and it still didn’t work. I later discovered that it was a Chrome incompatibility, and that it works on Internet Explorer. What browser are you using?

I am using FireFox, but I will try it in internet explorer and tell you if i see the settings and have it work.

Edit: It was FireFox and using internet explorer let me change the settings, but the bridge still does not want to connect. Here is an image of the settings.





4 quick questions:

  1. Why do you want to use a separate router to begin with? With the D-Link in AP mode you can connect directly to it with the laptops wireless card and thus connect directly to the robot no need for additional hardware.

  2. Do you mean that the router “will not” connect to the bridge?

Assuming that you did in fact mean “will not”…

  1. It seems like you should have to connect to your bridge to a specific SSID that matches the one being broadcast by your router as well as any associated security measures.

  2. Is the IP address that you selected for your bridge within the values on the settings on your router? The settings that you may need to check are on the router that you are using. If the IP address that you selected for your bridge aren’t within the range of values set by your router. If those mismatch, it will not connect

As a side note, if for some reason, it’s different bandwidths that’s causing the issue… ie your laptop doesn’t support Wireless N, which is probably why you’d bother to use a different router to begin with. The D-Link can be set to broadcast a,b, and g as well. Then you should have no issues connecting it in AP mode.

I was assuming that you would need a separate router to connect to the D-link when it is in bridge mode because that is how it was the last two years.
Anyway the D-link settings are exact to what the manual says to configure with no security. Also the IP are exactly right:
10.xx.yy.1
255.0.0.0
10.xx.yy.4

Correct me if I am wrong

What are the settings on your router? Does it use any wireless security?

This year you do not need a separate router to connect to your robot wirelessly. This year’s D-Link is both a router(AP Mode) and a bridge (just like last year’s). If you configure the D-Link with the instructions for the router and leave it in AP mode you do not need a separate router. Once you power up your robot, your laptop should be able to see the “xx.yy” SSID and connect to it. If for some reason your laptop is not able to detect it. Then there is probably a 802.11 band mismatch. You can avoid this by setting up your radio with the 2.4GHz settings, and selecting the “Mixed” mode which will communicate with most if not all laptops currently on the market. The only time the D-Link is restricted to Bridge mode is at competitions, when all communications flow through the competition network. Really the only reason you would have to use a separate router this year is if you were using a desktop for development, and you did not want to tether your robot to upload code to your robot. I’ve attached the most recent copy of “How to Configure Your Radio” for your review.

FYI… We had an issue earlier trying to connect our radio to our driver station Classmate PC. The 2010 Classmate doesn’t support 802.11N, so we had to revert to 2.4GHz and Mixed Radio in order to connect our driver station to our robot.

How_to_Configure_Your_Radio_Rev_A.pdf (942 KB)


How_to_Configure_Your_Radio_Rev_A.pdf (942 KB)

Thank you for clarifying that and i had it working AP mode before just wanted to see if i can have it work in bridge for competition. I don’t want to have any trouble during competition, but i will deal with that later and AP mode for now.
Thanks again!