Bug in the navX library

When we added navX code for 2023, it crashed on deploy. It gave us the following error:

Error at com.kauailabs.navx.frc.AHRS.(AHRS.java:227): Unhandled exception: java.lang.NoSuchMethodError: ‘boolean edu.wpi.first.util.RuntimeDetector.isRaspbian()’

Here’s the code in question.

We have the latest version of navX software (4.0.477).

1 Like

That is not the 2023 version of the NavX library (which is 2023.0.1 as of this post). Please see the 2023 link here: 3rd Party Libraries — FIRST Robotics Competition documentation

We actually just figured that out ourselves! Thank you for your help anyways.

Sometimes when we tried to re downland the NavX library, it wouldn’t let me. If you also encountered this solution, a solution I found was to just copy and paste the code in the new version and delete the old code.