Build Error(s)

Okay so I am trying very hard to try and make a build work from what was a known good program but now I just get a error list that I have no idea how to fix.

Yes, I did try to change the ‘workspace’ and think this is what is causing the problem but do not know how to correct it.

Help please.







Are all of your libraries referenced in the project properties?

The FRC2013 project seems like it’s not a robot project, based on the target directory.

For the errors in SimpleTemplate, I’d try to do clean and then build as a first step.

I have done the ‘clean’ and the image in the OP is after doing it.

Are all of your libraries referenced in the project properties?

I do not know. How would check?

I thank you for trying to help me but I am completely new to WindRiver and do not understand all the functions. So a lot of ‘hand holding’ and /or pointing me where to read would be very helpful.

Has your machine ever successfully built a C++ robot program? I haven’t seen this pattern before, but it smells a bit like some sort of installation issue.

It looks like you’re building the wrong kind of project. The build indicates that you’re trying to build a .exe which would be a native project instead of a VxWorks 6.x Downloadable kernel Module Project. Try to start from a clean workspace and do a New->Example->VxWorks Downloadable Kernel Module Project->FRC Simple Robot Template. Once you create the project, right click on the project and select Build Project. Hopefully it will build.

HTH,

Mike

Steve,

Yes this version of WindRiver with the required update has worked before in Building, Deploying and then running the Bot via the 2013 Driver station. The error now is from the same source that worked before we moved it (source) to a new directory.

Mike,
I try your suggestion after sign off.

Hi Mike,

Thank you very much for the input.

After we right clicked and deleted all the current projects and then followed your suggestion we back up and running again.