Build Robotpy-cscore from source

Hi, so I want to install robotpy-cscore for Jetson Nano python3.7, it’s written in the source code that robotpy-cscore support python3.6 + . From the official docs, to install robotpy-cscore for non-Roborio installation ARM Coprocessor needs to look up for robotpy-cscore wheels at Index of /~robotpy/wheels/2023/raspbian/ . However after I looked up in the link, there’s no wheel for python3.7 (cp37), instead there are only for Python 3.8 - 3.10.

Is there anyway for me to build robotpy-cscore from the source code? Thanks :smiley:

Are you trying to run robotpy-cscore on Ubuntu 18.04?

WPILib 2023 dropped support for all Linux distros older than Debian 11 (bullseye), including Ubuntu 18.04 and 20.04.

See Python NetworkTables and cscore on Jetson Nano - #6 by auscompgeek for details and alternatives (using older versions).

1 Like

Yea I use Ubuntu 18.04 in my Jetson Nano. Anyway, what I’m trying do to is not to install wpilib, I’m trying to use cscore to upload opencv frame to the shuffleboard, I’m not going to code my FRC Robot with python which means I dont need WPILiB, but I don’t think WPILiB dropped support for Ubuntu 18.04 in the docs they said “The following Linux distributions are known to work, but this list is not necessarily comprehensive: Ubuntu 22.04+”. I also have tried to install the WPILiB in my jetson nano, but it failed

I found the solution, as I said from cscore wheels built list there is no wheel for python3.7, so to Install robotpy-cscore for python3.7 I install the previous version (2022), I install the tar.gz (aarch64, Ubuntu 18.04) from State of Ubuntu_18.04_Ports for home:auscompgeek:robotpy / robotpy-cscore - openSUSE Build Service , after I installed the .tar.gz, I open it, then I run the setup.py file with python3.7 (python3.7 setup.py build)

I wrote the docs. WPILib components (including cscore) 2023 and newer will require a version of Ubuntu that is 22.04 or greater.

But as you pointed out, older versions of cscore will work just fine, glad you got it working for you.

2 Likes

The intent of the openSUSE Build Service repo was to provide prebuilt packages rather than source packages; the .debs would be the appropriate thing to install from there, as detailed on the install page.

Glad you managed to get things up and running either way.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.