Build successful but no robot code after deploying

Hello,
We’ve tried deploying code using a cable plugged directly into the roboRIO and over radio but the driver station keeps displaying that there’s no code even though the build is successful. We recently used the radio for a competition but already tried reflashing to get it back to the home version. Also, not sure if this is relevant but while our roboRIO was still reimaging, the robot accidentally got powered off which someone mentioned could potentially damage it.

Things we’ve tried:

  • Turning off firewall
  • Reimaging roboRIO
  • Reflashing radio

This is the log from the driver station:

Here is the link to the code if it helps: https://github.com/Aokijiop/FRC7447-2022-Clubapalooza-/tree/master/src/main/java/frc/robot

Any help is appreciated. Thanks!

It looks like the code is deployed yet is not running.
To be sure, you can try connecting to the roboRIO via SSH and check (using top or any other method) that the code is not running.
I saw this problem once (also with Java) and the solution was, using the imaging tool, to update the firmware and reimage the roboRIO (what you do when you get a new roboRIO).

1 Like

Updating firmware on the rio won’t make a difference, but reimaging might.

OP, while in the roborio imaging tool, also make sure “disable startup app” isn’t set.

It’s also technically possible that your code is crashing, though I’d expect to see something in the logs indicating it’s at least trying to start

1 Like

We experienced this problem last week leading up to our competition. The only solution that reliably fixed the issue was re-imaging the roborio.

Not exactly sure what the issue was or which action fixed it but updating the firmware and then reimaging the rio right after worked. Thank you!

In case this helps for someone looking at this later - I know this happened with us when we were coding on a couple of different machines and one had the latest WPILib and the driver station didn’t. The gradleRIO build version was newer and once we updated the firmware on the RoboRIO and WPILib on the driver’s station we were good.

I saw similar symptoms when a team had accidentally powered their robot off while deploying robot code. It seems that some cache somewhere had gotten corrupted in the process. It might be theoretically possible to fix it by doing something while SSHed into the RIO (or maybe redeploying the JRE?), but at the event we just fixed the issue with a reimage.

Turning off the RIO while deploying can corrupt the filesystem – I’ve seen this twice with the roboRIO 2. Reimaging (in that case, by removing the card) is the fix here. In some cases, the RSL does not light in this scenario.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.