C++ Catastrophic error in libs compiling

Our team is having trouble compiling code. It always returns the error message in short

    there is 1 catostrophic error 1st line #include "accelerometer.h"

if i were to delete the 1st line of sample code i get another error on the second line wiuth the exact same thing.

I would guess that we are missing some makefile.

but after downloading the wpi library several times, it still gives us the same error.

I am at a loss.

Please help!

Please post C++ questions/problems in the C++ sub-forum.
You need to:

  1. describe exactly what you did to “compile the code”.
  2. tell us what “it” is when you write “It always returns the error message”
  3. show (paste it in your post) the exact error.

Check the code that is just before the .h file. These are all read in in the order you put them in your code. Look for a character that shoudn not be there either in the code just before the .h or in the previous .h.

1.we use windriver so the program automatically compiles when you hit build project.

  1. windriver always returns an error message

3.this is a different computer that we don’t program on.

the error is as i can best descride it.

in the build of “project file location/AnalogChannel.cpp” line 7 catastrophic error (etoa:4005): could not open source file “CAnalogChannel.h”

Note: this was after deleting the accelerometer error. this is the second program in the file list after accelerometer. The same thing occured with CAccelerometer.cpp

thank you

we are presently making sure we have all the updates.

i do not believe this is the issue but it needs to be done so we are doing it.

It would save us both time if you could post a screen shot after the error has occurred.
Can’t you take a screen shot and put it on a USB memory stick and post it?
If for some reason you can’t post it, email it to gvarndell@hotmail.com.

okay i found the problem… for now. we got the crio imaged properly and now have a blinking light.
hurrah!

we’ll face the other problem later but i think it involves another update.

That’s great.
The forums are more useful to everyone if we all give back to them as much as we expect to gain from them.
Please consider posting an explanation of how you solved the problem.

we didn’t really find the solution we just got on the map as far as programming is concerned.

i’ll post something later about how we got to getting code on the robot that works.