C++ Deploy not an option under "run as"

My team started installing the FRC 2016 updates to the driver station, toolchains, eclipse plugins etc. on our programming laptops and when we fired up eclipse, the C++ deploy function that is normally found under “run as” in eclipse (whether clicking the green arrow or right clicking the project folder) is simply not there. The only option is local application.

We can still create new Robot template projects and build them with the WPI library, so the plugins for eclipse are working.

We have tried uninstalling and re-installing both eclipse and the frc toolchains to no avail. We are running windows 7 and are connected to the robot via USB only with all wifi adapters off.

I have run out of ideas to fix this.

Has anyone seen a similar issue? Eclipse without a deploy function is about as useful as Microsoft Word with no save function.

This happened to us last year, so I don’t remember the exact fix. Try playing with perspectives. In the upper right-hand corner of Eclipse, there is a button for “C/C++”. Just to the left of it, is a button for “Open Perspective”. Try switching to a different perspective and then back to C/C++. After switching back to C/C++, restart Eclipse.

-What platform are you running on?
-We had this problem on a Macintosh-based platform when the wpilib settings weren’t set correctly (or when they weren’t persisted correctly) - a topic for another post.
Martin Haeberli
Mentor
FRC 3045, TigerBots

It kinda sounds like the plugin isn’t installed. There is a step in screensteps live wherein you use Help->Install Software and you paste in a URL and select the FRC Robot development

To check if it’s installed at all (may still want to re-try installing it if you’re having troubles), goto Help->Installation Details and see which items are listed. Mine has:

  • C/C++ Development Tools SDK
  • Eclipse IDE for C/C++ Developers
  • Robot C++ Development

The Robot one is the plugin I’m thinking might be missing or mis-configured.

bob

This fixed it. Thanks!

We simply went under “window->perspectives->close all perspectives”, then “window->perspectives->open perspective->other->C/C++”, then restarted eclipse. Worked like a charm!

I was experimenting with the java and C++ builds with the 2015 toolchain, and wanted to be able to switch between the two. After having C++ Deploy vanish several times and having to reinstall wpilib, and reading last year’s thread on this topic, I found that I could preserve the C++ Deploy from disappearing (it seems to get wiped out when the java perspective is activated) by keeping a separate workspace for the my java and C++ projects. Then do File->Switch Workspace when you want to switch. I might have switched perspectives before switching workspace too, but not sure if that matters. Eclipse restarts but that’s OK. Not sure if that is the only way; it worked for me.

I have this problem too with our eclipse with c++. It only shows it after i restart eclipse. I’ll try these fixes.