Camera connection is lost after Driver Station sets IP


We are experiencing difficulties with our Axis Camera. We configured it with the Configuration Tool. The camera, cRIO and computer are all connected to our router. The computer can access the camera when it’s IP is automatic, but when we set it to (in order to communicate with the cRIO) the camera connection is lost. What can cause this problem?


It sounds like your camera isn’t configured to the right address. What options did you select in the Configuration Tool?

We chose the “Robot Radio” option. When I configure the computer’s IP as automatic I can access the camera at, I think that means it’s configured correctly.

I’m curious – how would the computer obtain an address if you set it to automatic?

Do you have both wired and wireless interfaces active? It’s possible that the wireless connection is already on the address and lets you connect to the camera through it, but when you try to set the wired connection to the same subnet things get confused.

Right now we don’t have a laptop to work with, so the computer I’m working with (which doesn’t have a wireless adapter) is wired directly with an Ethernet cable to the router (the camera and cRIO are also wired directly).

I’m not sure how the computer obtains the IP automatically, all I know is when it is set to “Obtain an IP address automatically” typing in Chrome gets me to the camera’s panel, but when I choose “Use the following IP address”, type and go to in Chrome, it doesn’t show anything.

Edit: I found a laptop to work with and connected it wireless-ly to the router (the cRIO and camera stayed wired directly) and it actually acted the same way. When I set it to automatic IP the camera worked (but no cRIO communication) and when I set the IP to the camera stopped working and the cRIO communications came back.

What IP address does the computer have when set to automatic?

When the computer is wired directly to the router running “ipconfig” gives me:

IPv4 Address:

When you say “router” you mean the D-Link DAP, right? It sounds like you haven’t configured it yet, and it’s still using its out-of-the-box settings.

But I don’t understand how or why that would give the symptoms you report.

This could be the cause of the problem we’re facing. We were told that in Israel 5Ghz routers are prohibited, so several D-Link’s we’re specialy manufactured for the Israeli teams.

Since they don’t make them any more, if something happens to ours we will be in big trouble. So for now we’ve locked the D-Link DAP in a place where nothing can happen to it, and we’re using another router, a BR-6424n Edimax.

You should configure the router you have to these settings:

IP address
SSID “1943”

But the important thing is that all devices should connect to one of the router’s four LAN ports. You should plug NOTHING into the WAN port. I’m guessing that’s the cause of the problem you’re having.

And there’s no reason to use the WPS feature.

Thank you very much!!! Everything is working now! I’m not sure if it was wrong router settings or that the camera was connected to the WAN port.

I told another team mate about your post and he reconfigured the router, disconnected everything and connected them back to the LAN ports (when I asked him about it he said he didn’t remember if the camera was connected to the WAN port).

Anyway, thanks a lot! If you have a moment: we’re still having problems with using NetworkTables.