CAMERA DOESN"T RESPOND!!!!!!

I followed all the instructions and built my cam according to the mount assembly instructions.

  1. Then i take servo pan and hook it upto pwm 01
  2. Then i take servon tilt and hook it up to pwm02
  3. than i power the camera throught pwm03
  4. I load the camera code into the robot
  5. Turn the green lights on

As a result I get no results all i see is my camera moved and its facing the ceiling. I thought the camera is suppose to scan for colour green but it doesn’t do anything? Can anyone help me troubleshoot the problem and get the camera to work! Please and Thank You :slight_smile:

E-mail: [email protected]

Is the operator interface tethered to the robot controller with the red cable? If so, are all of the LEDs on the RC and OI green? If they are, double check that you’ve got the serial port connected correctly and then run the serial port diagnostics mentioned in Q13 and Q14 of the CMUcam2 FAQ: http://kevin.org/frc/camera.

-Kevin

I did all that and i even ran the diagnostics but it said something like searching or diagnosing… something like that and I waited for 5 minutes and still no results came up so i thought that everything is fine! :confused: Also when i tried to use last year’s GUI it didn’t work like it said camera ready but all i see is black! no histograms nothing. i even tried to move servos using GUI but they didn’t move!

If your camera initializes pointing up instead of forward, maybe the servo wasn’t centered when it was mounted to the tilt assembly.

If you only see black, maybe the lens cover is still on the camera.

We did remove the lens cover. Are their chances that our camera is broken or something internal problems? If so what can we do about it meaning can we get a new one? From where?

Is it Focussed right?

Just clarifying: After it said “Camera Ready” you clicked “Grab Frame”, right?

Also, if you were trying to move the servos from inside the GUI, you must have the servos plugged into servo ports 1 and 2 on the CMUCam board.

Oh no wonder my servos didn’t move thanks! however ya my camera was focused it said camera ready. however when i see the GUI window everything is black also I wasn’t able to grab frames or do anything? In other words i wasn’t able to use GUI although GUI was able to recognize the camera it didn’t help me! Should i assume that the camera is broke or their is the problem in GUI?