Camera "Grab Frame" Problems

Hey guys! I’ve been working with my team’s camera and the first time i did it, everything worked and the camera was grabbing frames but everything was really fuzzy. But now that i go back to it, the “grab frame” option doesn’t even seem to be working. It’s not loading a picture and the system freezes on my computer. Did i miss a step the second time that is screwing up my camera? You tell me.
Team 0974

As for fuzziness, make sure the camera is in focus. You can adjust the focus by turning the lens ring on the camera (or so I understand).

Did you have it verify the camera (as stated in the “” file, so that it shows the camera type in the text box up top, and “FRC” in the bottom-right corner?


The application seems to crash a lot on our computer as well. Usually we just have to end the program and restart it. If this doesnt work, cycle power to the camera and robot, and make sure the backup battery is plugged in and charged (this seems to matter for some reason). Also, If you are using the camera on the computer it seems as though it cannot be plugged into the RC TTL port as well, so make sure this is unplugged.

we did try to focus it by turning the ring on the lens but it didn’t do very much. the focus was very minimal.
as for what’s wrong with the program, we’re getting an error message with
the config.txt file whenever we upload the system. any thoughts on that? because i don’t remember it ever coming up before (obvioulsy becasue it worked the last time, other than it being out of focus) but we don’t know what’s wrong with the file therefore we dont’ know how to fix it.
thanks guys!
team 0974

well we figured it out. it was really simple too which sorta pissed me off: you need to have the program running before you run power through the camera and the robot controller. also, we were using compressed files; that’s what the error message was for.
thank god for genius mentors!
thanks for your input i appreciate it!
Team 0974

I haven’t found this to be true. In fact, I always have the camera powered before I start the GUI. I guess it’s just peculiar to your situation.

I have always powered up the camera first, but whatever works for you…