Camera - how to get out of B&W?

The camera works great - we can see it fine on the dashboard. (That dashboard is nice!)

I set up the green light thing from the contest two years ago about 10 feet in front of the camera. (I’m guessing there is a camera needed this year, duh…) It showed up as white. In fact, the entire image was B&W. If I point the camera straight up at the ceiling lights a few colors start to emerge.

I played with a few settings via Labview but I couldn’t change anything.

Any thoughts? i.e., how do I configure the camera to see in color?

And I misread the question entirely, thanks Mr. Bill.

You may want to take a look at this tutorial.

(The reply that was deleted was *almost *perfect…)

I’m having trouble getting the camera to return RGB. Basically I find only two places to set RGB deep in the Labview bowels (not sure if U32 or U64 is right - I’ve tried them both).

Basically the camera will show color for about 5-10 seconds, and then it reverts to grayscale. It may last longer in color if it’s pointed at least partially at a bright light. However, the ambient light in the room should be much more than adequate for normal operation.

Can you think of any other thoughts? Documentation on Labview/WPI camera vi’s that will move me along?


While interesting, documentation on image processing is not the issue at this point. Need to get the camera working first… :slight_smile:

After reading this description of the problem, I agree that processing is not the issue. I also believe that configuration is not the problem either. My bottom line guess is that the camera is defective.
It may be a simple as a loose connection internally, or it could be a bad solder joint. Regardless, I believe it needs to be swapped out.

(Hey, in my case it’s usually operator error…)

We’ll swap cameras - thanks!

If you haven’t done it already, you might try a hard reset of the camera. I think it involves pulling the plug, holding the black button on the back down, reinsert power and wait ~20 seconds until the lights on front blink red/green.

You may also want to check to see if the camera color setting is being modified. It defaults to 50. Smaller numbers move towards grayscale, higher numbers saturate the colors.

Greg McKaskle

Try this: First learn how to access the camera settings and capture images using your PC browser – see the camera user’s manual for that information. Reset the camera so everything returns to factory default.

Then let the green light warm up for 5 or 10 minutes.

Position the camera about 6 or 7 inches in front of and pointing directly at the green light. ( 6.7 inches works best for our team ) Allow the exposure to stabilize while watching “Live View” on your PC browser. You should see a nice green color fill the entire image if done correctly. (and if the camera is not defective)

Then go to Setup, Video & Image, Advanced.

Set the exposure level adjustment drop-down to “Hold current” and click “Save”. The exposure setting will then be fixed and won’t change automatically as you move the camera around. The exposure setting will retain its value even if you power-cycle the camera.

You should also set the “white balance” to “Fixed Fluorescent 1”, although that setting isn’t as critical as the exposure setting.

With these settings, you should be able to capture nice green lamp images no matter how far away the lamp is positioned.

I plan to post more detail on this on Think Tank within the next week.

Dave D

Are you using the wall-wart power supply or is it plugged into the PD?

If the PD, are you ABSOLUTELY sure it is plugged into the correct power port?

An incorrect exposure setting will make the green light appear white - did resetting exposure as DaveD suggested work?