Camera Image on Classmate

We are having an issue (not a crisis) with the axis camera (model M1011) (mentor wants me to insert exclamatory punctuation HERE). Here is a brief description of the problem:
Before we updated the classmate we tried to run 2013 code on the robot (cRio on current version) the camera image was being displayed at 30ish FPS. We updated the classmate. All old versions of LabVIEW are removed. now we cant get an image on the classmate. we can run the robot fine, all the dashboard indicators are updating. We are getting a FPS and bitrate below where the camera image should be (like normal). When I run the DS on a different computer I can get the image through a tether and through wireless. also we are running an 8-Slot cRio but all camera images are being run through the wireless bridge. the camera’s IP is (normal) does anyone know why the image is not showing up on the classmate, but it is on a different laptop?

great question, I’m sure someone out there has a good deal of insight into it.::rtm::

A likely possibility is that the Vision installation from the LabVIEW DVD that came in the Kit is corrupted.

Reinstalling just the Vision tools will fix it if that’s the issue.

We had the exact same problems last year. The solution we came to, was to reinstall LabVIEW. Uninstall everything and install again.

More specifically, it appears that the NIVision component is not decoding the jpeg or not displaying it. This is either because it isn’t activated or isn’t compatible with what is being asked it. You may be able to uninstall and reinstall just the NIVision Runtime Engine or a similar NIVision component. In Add/Remove SW, it will be under the National Instruments category.

Greg McKaskle