Camera not Sending to Dashboard

Like most teams (from what I can tell) my team plans on using vision processing at least in part for our final design. While I may be a senior member no one on our team has ever used the camera in FRC and as such we are running into problems that appear to be expected for rookies to the camera.

I run all the default code building the programs with absolutely nothing modified and than running the driver station. However, when the top part opens I see a blank image where the camera image should be.

To state some facts we are using the 206 camera FRC provides. I have reimaged the CRIO and updated the driver station to the most recent version and the camera is plugged into the 5V power and crossover cabled to the Bridges second port (1st being the CRIO).

I believe we set all the cameras information using the tool provided but until I get back to work tomorrow I won’t be able to confirm if that was the problem. If there is any critical part that my team is missing to set up the camera please please tell me.

Lastly I analogize for the bad forum quality as you can see I am new to posting on forums, also if you are willing could you explain why the camera has the last 2 digits of it’s ip set to 90 but when the labview default programs call it they call 11 that seems very… strange. Again thanks a ton.

We are actually having the same very problems! The only way I can get it to work is to reset it then use the axis configure tool again. Once we loose power on it and start it up again nothing works. It lights up like it should and all but no images nor the web server starts up. I have no idea why it isn’t working. We have had this problem for days.

Your beating my team at least you get an image once. Please give me an update if you find any solution programming has basically stopped until we can fix this.

Looking at the LabVIEW code and dashboard code it looks like the default has switched to hooking the camera up to the switch this year. Both defaults are looking for the camera at 10.xx.yy.11

Im guessing the word switch means bridge or router etc… Anyway yes I noticed this as well but the camera tool provided to us sets up the camera IP to end in .90 which I feel would cause serious issues.

Yes, when I said switch I was referring to the robot radio (white DLink device).

Our camera was already set up for the switch so I didn’t even open the new tool. It sets it to 10.xx.yy.90?

Actually the dialog box to the right of the tool reads similar to a standered router ip with a .90 ending.

Could you possibly send me the instructions you used to make your camera function properly that would be a great help. Also are you running your camera through the CRIO or the bridge (my CRIO’s second Ethernet port is died so I must use the new bridge configuration). is the default camera IP and the IP for using cRIO port 2.

Ours is running through the bridge. I set the camera settings up manually last year, but I just looked at the Getting Started with the 2012 Control System document on the FIRST Kit of Parts Technical Resources website and it says this year’s tool has an option called “Robot Radio”. The camera configuration is on page 27.

As i said originally I was not the one who did this operation for the camera but I was informed they did it correctly. If this is where the problem keeps leading I’ll hopefully check this out tomorrow and report back.

I just re-read your first post an saw Crossover cable. I’m not sure if the robot radio has auto sensing ports (allowing a crossover to work), but you theoretically should be using a patch cable, not a crossover.

What I would try is set up the camera with the tool, and leave it plugged into the PC. Change your PC IP to 10.xx.yy.5, open a browser and go to 10.xx.yy.11 Username: FRC Password: FRC. This is the configuration the Dashboard is expecting. If that works, then try moving it over to the switch.

We can get to this. Once power is removed and put back on it no longer works :confused:

To review, there are multiple ways to configure and use the camera.

By default, the dashboard expects the camera at To change the IP to something else, rebuild the dashboard from source. This configuration supports reading the camera form both dashboard and robot. This is the recommended configuration.

If you prefer and have an 8 slot, you can use the setup above, or you can use port 2 on the cRIO. If using port 2, set the camera IP address to, set the camera IP in Begin or in the constructor, and change the dashboard to use the retransmitted image server.

Greg McKaskle

Alrighty well we have gotten down to the point where everytime I plug it into my desktop I can connect to its web server just fine and it displays the image. But labview and the crio don’t see the image.

I have setup two accounts on it. user root password admin and user FRC password FRC. Is there anything else I should be doing?

This is precisely the problem we are having. We have gone through two cameras. We can configure them and then connect to the dashboard fine.

We we remove power and turn the camera back on again, the camera has lost the IP address.


Is this an Axis 206 or M1011?

Ours is the 206
Tomorrow morning I will pull up last years manual configuration guide and go through it. If that work’s then we will have found a solution.


Here is a copy of the PDF for configuring it last year in case anyone would like to do the same as me.

I think the difference from this years configuration and last years is the FRC user. I didn’t have it added last year. Just the root user. Possibly that’s the reason I’m having issues. I’ll try removing the FRC user tomorrow and see if then it works. Possibly trying both accounts and causing an issue somewhere. Hmm.

The FRC FRC account shouldn’t hurt anything, and in fact, it is the credentials that LV uses first. I don’t know the details for C++ or Java. If you delete it, LV and possibly the others will fail the connection several times before succeeding.

Please describe the camera IP, cRIO IP, and DS/development computer IP and how they are networked (what ports, etc).

I typically use a 4 slot, but if I use an 8, I connect port 1 to the dlink. Port 2 is unused. Then I connect everything else into the dlink using standard patch cables. I can then run the DS & DB and it work. I can run Vision Assistant if I want, and I can run LV examples on the computer or the cRIO and they work.

Greg McKaskle

Alright, We had finally got it working. What we had done to get it to work is created a new dashboard in LabVIEW. I added a cameraIP output (like the robot IP output) and then it worked. Yet, the default dashboard still doesn’t work. Here is a copy of the dashboard I built:
Sources are also on that page.

Also, I manually configured the camera to its static ip 10.xx.yy.11 like the config software should. Not sure if this made a difference or not. Made the default gateway 10.xx.yy.1