Camera Problems (with latest WPILib update)

Every time we upload the basic camera code to display the camera image on the driver station, we get a “No Robot Code” error. Here is our code:


AxisCamera &camera = AxisCamera::GetInstance();
camera.WriteResolution(AxisCamera::kResolution_640x480);

while (IsOperatorControl()) {
camera.GetImage(image.GetImaqImage());
}

The camera is plugged in correctly. We ran the latest WPILib update (from Feb 17, v4.3) and it worked perfectly. Then, the next day we started getting the “No Robot Code” error again. Nothing was changed. The cRIO is imaged to v19. We’ve redone the update and tried everything else we can think of, but we’re completely stumped. :ahh:

Does anyone have any ideas? Thanks!

Team 102

You have the latest version of WPILib, but an older version of the cRIO image. You need to install v20 on the cRIO.

Greg McKaskle

Here is a link to a thread that speaks to using the M1011 camera replacement.

http://www.chiefdelphi.com/forums/showthread.php?t=81945

It also contains a link to another thread that discusses updating the camera code to accommodate the M1011 substitution. :slight_smile:

I don’t know of any library changes needed for using the other camera.

Greg McKaskle

We updated to v20 and it still doesn’t work.