Camera Setup

Okay so our team wanted to keep off the camera setup and all until we got everything in our original design working perfectly, so basically we just started with the camera configuration, I typed it all out in a text file before we left for the day so that I could get help so here is all the info:

Using cross-over ethernet cable
Firmware Version 4.40
MAC address: 00:40:8C:8E:D1:15

Username: root
Password: admin

We are using the “Use the following IP address” option [not “obtain IP address via DHCP”]
IP address:
Subnet mask:
Default router:

Enable ARP/Ping setting of IP Address is checked

Video & Image are all defaults

So we plugged the crossover into our laptop and were successful in getting the image with the above settings. So then we hooked it to the robot and tried to get an image, and didn’t know how. So:

  1. Can you even receive an image from the camera when it’s hooked to the cRIO?
  2. If yes, how?
  3. If no, how can you get feedback from the camera that it sees anything at all?

TY to any who reply. :smiley:

If you’re using one of the LabVIEW frameworks, then the camera code is built in and you can see the camera output by running the default LabVIEW Dashboard project.

We are using Windriver [but we have LabView installed]

Is there a way that we can get the image on the screen through Windriver?

I have another question

  1. Is there the way to see what the camera sees through WindRiver?
    2)if I switched the cRIO and did labVIEW just to look for the camera and go back to WindRiver cRIO, 1st can you even do this? 2nd if you did do this would it dmg the cRIO, or screw up any IP addressing??

First of all, the camera when plugged into the cRio it’s on a different network from all of the other systems. Therefore, you can’t acsess it directly. Since you’re using windriver, you’ll need to manually start a video server–check the C++ reference for the “PCvideoserver” object. Remember to take video server code out before you compete however–it will just bog down the CPU and bridge.

As for switching development environments on the cRio–just make sure you put in the team number right and that the current configuration matches what you’re actually using, and it should work fine.

Probably the easiest way just to test the camera is to reformat the cRIO using the FRC cRIO Imaging Tool. That puts the default program back on the cRIO and it streams the camera back to your PC.
You can leave the cRIO formatted for Wind River, so your regular programming won’t get messed up.

Then use “FRC Dashboard Project” from the LabVIEW startup window and run it by right clicking on Dashboard and clicking Run.

If the camera is setup correctly you’ll get the video.

Okay wanted to get back to you. So I used the method of doing the cRIO tool, and checked the bubble LabView. I was able to successfully get the image from the camera once I opened up the FRC Dashboard thing. Then once I had confirmation that it was working correctly I went to the cRIO re-image tool yet again, and then checked the bubble WindRiver, once that was done I went into WindRiver, and did FIRST->Undeploy (like the reimage tool said) restarted the robot, then went to FIRST->Download and restarted the robot again and by battery it said No Code? What do I do to fix this I checked to see if it was using the right file under Window->Preferences and went to the Kernal task even, I even pressed Run, but nothing worked :ahh:

can any one help with the above problem? :confused:

Nothing off the top of my head, unless it’s something simple like your team number got entered incorrectly when you reimaged the cRIO. But that’s easy to test just by running the pinger, and you’d get an error message from Wind River anyway.

Downloading should work all by itself to transfer the file specified by Window -> Preferences without regard to the Imaging Tool or even Undeploy.

No error messages, it appears to download, but nothing runs after you restart the robot…

I assume you are up-to-date with the latest:
-Wind River Update 3 1/27/2009
-the cRIO has the v11 image on it now,
-and the Driver Station has firmware version 2009-02-10a3

Any useful status displayed on the Driver Station?

Okay so I undeployed it restarted, tried to debug and it says

symbols not resolved

Then our DS display is the following if I do FIRST->Download, and restart the bot.

Team: 2429
Mode: Teleoperated
System: Enabled
Battery: No Code
DS Rev: 2008-10-29a

yes I updated the cRIO with th version from 1/27, but if there was another one after that then I don’t know about it. Also I checked the Window->Preferences. The only thing is that when I re-imaged it to get the img from the camera I checked the bubble LabVIEW, and then once I got it, I re-imaged the cRIO with Wind River and after I did that it no longer works, what should I do I am thinking about resetting the cRIO and then re-image it again, what is your suggestion?

So that didn’t work. [resetting the IP address and then re-image cRIO] I have gone into Kernal Task and tried Debug as well as Run. I have no idea what is wrong and no matter what I always get No Code by the battery.