Camera to DashBoard

We are having a lot of troubles to connect m1101 camera to default dashboard.
We have tried to connect the camera to cRIO Port 2 , ran the code AxisCamera &cam = AxisCamera::GetInstance();, and it didn’t work.

So we changed camera ip, and connected it to the radio, and it continue not work :confused:

Does anyone know a solution???

What happens if you open a web browser like Internet Explorer and enter in the address bar? If prompted for a Username and Password use “FRC” for both. It should bring you to a webpage where you can view the camera image.

If you have updated the C-Rio then you connect directly to the radio, meaning that you have to re run the Axis utility and set the ip to: 10.xx.yy.11. Hope this helps

When I type it opens a webpage, and, we have updated the cRIO, but any of those worked to get images from camera to dashboard, we are using C++.

I tryed now to cam.GetImage();
and yes i have created a FRC/FRC account.
But the dashboard continue not showing camera images :confused:

If that webpage and login work, your camera is set up correctly and accessible from your DS computer. That means that something is preventing the Dashboard from getting the image stream. Try turning off any firewall including Windows Firewall and see if that helps.

We have it turned off.

but, you know if we have to patch any WPILib file, or something like that?

You have to be using the 2012 Driver’s Station, but it shouldn’t matter if you’ve gotten to the language updates or put code on the robot yet (I don’t think)

We are using 2012 driver station, and languages updates, But only making GetInstance(); from program should work ??

Yes that should work for the robot side, but that shouldn’t even be necessary for the Dashboard to show the image in this configuration. I’m not sure why yours isn’t working. I’ll certainly post here if I think of any other ideas though.

We are having the same very issues! Except with labView. Dashboard isnt seeing it.

The vision assistant does see it though. Dashboard and labview code dont.

Vision Assistant requires that you enter the IP address. What was the address that worked?

Greg McKaskle