Can Bus not Working Once Whole Drive Connected

I have a swerve drive using 8 falcon 500’s, 4 CanCoders, and a Pigeon 2.0. I have them connected in the following order:

Back Left, Front Left, Pigeon, Back Right, Front right.
Everything seems fine for the first 3 modules and the Pigeon. However once the last module is connected all the Falcon lights turn Red and I am getting CAN errors. I have tried wiring each module individually and they work fine. When this error happens is inconsistent. Sometimes it occurs when the fourth module is attached. Sometimes I can get all 4 modules connected and when the Pigeon is connected it will stop working. I have tried bypassing the pigeon and it still occurs. I have also run into instances when the lights will be normal until I connect the Tuner. If I deploy diagnostics then they will change color.

We had an issue at one point where if we applied pressure to connect the wires by hand it would work but without that pressure they would blink red.

Check that you are properly terminating the CAN bus at both ends and super-double check your wiring. I have a small oscilloscope that is very helpful for this type of problem, it’s pretty common these days, with almost everything on CAN on many robots. You can see some types of problems this way, but there’s a learning curve. Most of the time, checking the wiring sorts things out.

I checked the entire loop and found an issue with one of the CanCoder Solder points. Fixing that connection corrected the issue. Thank you.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.