CAN can not see PDP

Before I updated the RoboRIO, I was able to see the Power Distribution Panel in the dashboard. After I flashed the firmware and Imaged the RoboRIO to the 2016 game, the PDP disappeared from the dashboard. I am still able to see the PCM in the dashboard and I am still able to see the battery voltage in the driver station.
I have tried to reflash the RoboRIO and flashed our other RoboRIO with the same results.

What are the LEDs on the PDP doing?

Did you make sure that every CAN wire was terminated into something? I had a similar problem before, where I couldn’t see a couple of our Talon SRX’s on the dashboard. The issue ended up being that I had a CAN cable plugged into one of the two ports in the PDB, but not attached to anything else on the other end.

I have CAN wire go from the RoboRIO to the PCM to the PDP witch has the terminating resistor. I was able to see the PDP before I flashed and afterwards it disappeared from the dashboard but still able to see data in driver station. RoboRIO1’s PDP just flashes green and RoboRIO2’s PDP flashes orange.

PDP disappeared from the dashboard. 

You mean the web-based roboRIO configuration page?

But if the RIO was reset and the browser was not manually refreshed, the silverlight plugin won’t match CAN devices to the treeview on the left correctly.

Can you just try a simple power cycle of the robot, and cleanly close/reopen the browser?

If the PDP is not red, then it has healthy CAN.

Battery voltage in the DS comes from the RIO, not the PDP, so that shouldn’t be used as a clue for PDP.

To rule out wiring, a simple sanity check would be to just plug a yellow/green cable from the RIO CAN BUS port right to the PDP’s CAN Bus Port.

Then power boot and open a fresh web-based config page.

I have two test beds one with CAN going from RoboRIO to PCM to PDP and I can only see the PCM and another test bed with just CAN going from RoboRIO to PDP. This same issue is happening to two different RoboRIOs

On the PDP that is connected to the roboRIO directly (no PCM), disconnect CAN and confirm the PDP LEDs change to blink-red-only. Then reconnect the CAN wires to the PDP to confirm it transitions back to blink-green-only (or blink-orange-only due to sticky fault).

Be sure to clear the column filter on the left above the treeview.

Make sure jumper on PDP is on the TERM. ON position.

Follow the cable from the RIO to the PDP to ensure CANH goes to CANH and CANL to CANL.

Sanity check: the PDP was flashed with 1.40 and the RIO was flashed with image19?

Green goes to green and yellow goes to yellow. While we were talking, the PCM also disappeared. When I disconnected a CAN wire, it did turn red and when I plugged it back in it turned orange. I do not know what firmware the PDP is because I can not access it. The TERM jumper is on ON.
http://i.snag.gy/0elGY.jpg

Seems like there is something fundamental that is wrong. 2 RIOs and PDP and PCM are misbehaving? Maybe there is something going on with the actual wires.

Try this, grab two clean/prestine new wires, cleanly strip them, insert into the RIO and PDP’s weidumuller connector. Be sure to press down on the white button before inserting the wire. Tug-test them by pulling on the insulation and make sure the wire doesn’t pull out (doesn’t require too much effort)

Video on inserting wire: https://youtu.be/kCcDw3lDYis
Source from: https://wpilib.screenstepslive.com/s/4485/m/24166/l/144971-wiring-the-2016-frc-control-system

Maybe a photo of the wiring between RIO and PDP will reveal something obvious?

Here is a picture https://goo.gl/photos/Lj2NTgJo9ihDbbcs8. I used a new CAN wire from the KOP and still did not work. When I restored the image from 2015, CAN worked.

md5: FRC_roboRIO_2016_v19.zip 71641743A49F10B8FB61CFDD1A8FDF29

When the problem was happened was there code deployed? I’m wondering if reimaging ‘fixes’ it because a deployed app gets wiped away.

The problem happened when I imaged the RoboRIO to the 2016 gamehttps://wpilib.screenstepslive.com/s/4485/m/13503/l/144984-imaging-your-roborio when I went back to 2015 game, the CAN started to work again.

Another sanity check:
Is the firmware of the RIO 3.0.0f0 as reported in the web-based config?
(not the same as the RIO image).
http://wpilib.screenstepslive.com/s/4485/m/13503/l/273817-updating-your-roborio-firmware

EDIT: Nevermind, its 3.0.0f0 in the screenshot

I am still having this issue. The CAN works in the 2015 game but in the 2016 image the CAN disappears. Can someone verify the Hash check that I posted before. I don’t know what else it can be if no other team is having this issue.

The hash compared okay to mine.

Can you email [email protected]? We’ll figure it out, I’m wondering if there is some subtle hardware issue with either RIO or PDP.

Seems strange that your seeing multiple things disappear with multiple RIOs.

So the root-cause appears to be an anomaly with the 2016 web-based plugin that occurs only if there is a small number of devices (one or two) that have large device IDs (in this example both PCM and PDP were 62).
This limitation has the affect of a device not populating in the web-based config device list, even though CAN and robot API are working, which was the rakosi2’s observation.

This has no impact on the roboRIO’s API or your ability to control/monitor from robot-code.

For this functional limitation to occur there must be
[1] A small number of devices (typically one or two)
[2] All devices must have large device IDs (> ~30)

I came up with an easy workaround in case anyone gets bit by this.
If you have a device that isn’t showing up on the web-page despite its LED(s) indicating good-communication, you can force it to appear with the following steps…
[1] Disconnect the CAN wires (or power) to that device while RIO is off.
[2] power boot the RIO
[3] navigate to the web-based config, wait a few seconds so it has a chance to fully render
[4] Then connect CAN (or power) to that device
[5] Manually refresh the page and the device will appear.
[6] At which point reduce the the Device ID (recommendations below).

For PDP I recommend using device ID ‘0’ (seems to be be necessary if C++ users want to read PDP signals).
For PCMs I recommend starting at ‘0’ and counting up .
For Talon SRXs I recommend starting at ‘0’ and counting up.

I’ll update the docs accordingly, thanks rakosi2 for helping diagnose the problem!

We were seeing the same problems with one of our old PDPs. It turned out that the PDP was running firmware version 1.3. It needs to be running version 1.4. Once we did that upgrade, the problem went away.

You can get the firmware image and instructions here:
http://www.ctr-electronics.com/pdp.html#product_tabs_technical_resources

Hey All,
Bringing this thread to a close, a write up of this functional limitation is in the Talon SRX Software reference guide in Section 21.23.
http://www.ctr-electronics.com/talon-srx.html#product_tabs_technical_resources

Other product docs will be updated accordingly.