CAN Issues

We are looking into using CAN this year and are having difficult getting started. We are first trying to get a single Jaguar to operate in CAN mode. We used BDC-COMM to assign a new ID (2), updated the firmware, re-imaged the cRIO with the Black Jaguar CAN option, and inserted this into the code:


When we run the program and enable the robot, the Jaguar LED is steady amber, however, it doesn’t respond to the joystick. We’ve tried replacing the joystick with a front panel control, but still no response. Are we missing something?

Thanks.





Everything you’ve mentioned is correct, and your code looks fine.

Do you have the RS232-CAN adapter wired to the left CAN port on the Jaguar?

Are you getting any errors on the Driver Station? (Go to the diagnostics tab)

solid amber rules out a wiring fault as long as all jaguars have solid yellow.

make sure your motor is connected and good

in the worst case, use bdc-comm to manually test the jaguar (use the “mode” tab and drag the slider to set the speed)

When I got back to the shop today and hooked everything up, it worked. As far as I could tell, nothing had changed. We then tried adding another Jaguar. It shows up with Enum, but doesn’t respond to joystick input. Didn’t have time to do any debugging.

Perhaps your Jaguar is powering up after it is supposed to be initialized, and thus missing the “voltage mode enable” command in Begin.vi. This can happen in systems with low battery voltage or noisy power supplies.

To test this, you can place a “get output” VI and see what output your Jaguar says it’s getting. If it’s not enabled, it will say its output is zero.
(This differs from the “output voltage” status in that this will change depending on the control mode the Jaguar is in, whereas the “output voltage” will always give you the voltage provided at the motor terminals)

Thanks, I’ll give that a try when I’m back in the shop on Tuesday.

The “get output” for the second Jaguar (id #4) always returns 0. The other Jag (# 2) works fine. This is the case regardless of the order of the Jags (cRIO-2-4, or cRIO-4-2). Both show up in enum. Any suggestions?

It sounds like #4 isn’t getting enabled in Begin.vi, for some reason or another.
Try “enabling” the motor again at the start of Teleop, and see if it helps.

Another thing you can do is check the “power status” on Jaguar #4. If indicates a power reset more than once, then you need to check its power wiring.

I’m having a setup issue with our Black Jaguars. I am unable to assign a new ID and when I try to update the firmware I get an “Unable to contact the boot loader!” message.

Mode tab: I am able to move the slider to adjust the settings at the bottom of the BDC-COMM screen when connected.

System tab: Board information is: none,none; Hardware Version: 0; Firmware Version: 0; New Board ID: 1

Ideas??

Yes, you have a communication issue.
Check your wiring. Especially make sure your RS232-CAN adapter is correct. When looking at RJ14 connector with the gold terminals up, as if to plug it into a socket directly in front of you, the color order (left to right) should be:
white, black, red, green, yellow, blue.

Have you gotten this to work with other Jaguars?

No, this was the first attempt and we made the cables yesterday. We’re using RJ12 connectors with Cat5e cable with the green pair removed.

I would think that would be more difficult than flat ribbon cable.

I was having the same problem, it turned out that I had switched the TX and RX pins on the custom adapter cable. Also be sure you’ve connected GND to GND on the adapter cable. The yellow solid light can be acquired by connecting the V+ and CAN_L or CAN_H to the DB9 adapter. Hope this helps :slight_smile: