CAN Jaguar Firmware Update Problems

Is anyone else having trouble using BDC-COMM to update the firmware of black jaguars?

Initial connection is fine, and we are able to assign a CAN id without problem, but when we go to update the firmware, it gets about 10% done and freezes, the jaguar light goes off and stays off.

We hunted around and found this solution:
1)
C:>bdc-comm-107.exe -c N

  • replace the ‘N’ with the COM port number you are using

id X

  • replace ‘X’ with the ID you had previously set for that Jaguar (factory default is 1)

update black-jag-v109.bin

which worked for one of the jaguars. So we repeated the process again in the bdc-comm gui on another jag, assigned id with no problems, tried to update the firmware. It froze again, so we tried the command line approach as above, only this time, the command-line version also froze during firmware update.

Any ideas? Is it possible to configure and update the jags through the roborio’s browser-based configuration tool?

Thanks

Yes. It’s as simple as opening the webdash, finding your Jaguar, and clicking the update firmware button. I’m not sure if the v109 update was tested over BDC Comm during beta. I know we didn’t.

The Jaguars only support changing IDs on the roboRIO web page. Firmware must be updated using BDC-COMM.

The CTRE devices only use the web interface.

The command-line version and the GUI version share an implementation in the background, so I would not expect the behavior to differ based on which you choose. I haven’t seen it hang like that when programming a single Jag on an isolated connection or when updating a Grey Jag while using a Black Jag (with a different ID) as a bridge. My only recommendation short of making sure your connections are as I described would be to try again. It worked for you once. Perhaps whatever is causing you trouble will be intermittent enough for you to complete updating all your devices.

We have to resort to the command line version once the jag light starts refusing to turn on. The GUI version assumes there is no jag connected and won’t let you update, whereas the command-line version lets you force it to try to update, which worked for the first one.

Hopefully we can recreate the first result, though the last time, when it froze in the command-line version, it locked up the cmd window and wouldn’t respond to ctrl-c, killall, or taskmanager force quits.

Fingers crossed I guess.

Yes. It’s as simple as opening the webdash, finding your Jaguar, and clicking the update firmware button. I’m not sure if the v109 update was tested over BDC Comm during beta. I know we didn’t.

By the sounds of this, Jefferson was successful in updating the firmware using webdash, though jhersh doesn’t think this is possible?

Joe would know better. I checked the webdash last night and the update firmware button is not on there. JDN must have updated the Jaguar firmware during beta. I remembered updating firmware in the webdash, but that must have been the CTRE devices.

Sorry for the confusion, and thanks for the correction Joe.

This is because the Jaguar has gone into recovery mode. When there is no light on the Jaguar anymore, yet it is being powered, select (IIRC) Recover Firmware instead of Update Firmware. It should still be under the File menu. Make sure it is the only Jaguar connected when using this method, and it should recover itself.

Ok excellent, we will try tonight after verifying there are no problems with our cables or the contacts on the jags.

Does this Recover Firmware flash the new firmware to it as well, or will we have to retry Update Firmware after they are recovered?

Thanks for the help!

It will load the firmware as normal, (hopefully) making it usable again. Are you using a USB to serial adapter? (If you have access to one) try using a computer with a native serial port on it. I have heard reports of some adapters working fine for everything but the update process. (For reference, I have been using a Keyspan USA-19HS for years without problems.)

We are using a USB-serial adapter. If the problems persist we’ll give it a go on one of the school’s desktops with native serial. Thanks for the tip.