CAN not appearing on web configuration

I had sticky faults on the PDP and the PCM. I connected the rio to the computer and tried to access the web configuration. So our first RoboRio was not showing CAN on the web configuration. I figured an issue happened when I used the 2018 rio image tool. So I imaged it again. Did not work. I got our second rio out and hooked waited to reimage it. I connected it to the web configuration and it showed all the CAN components. I reimaged it using the tool and went back to the web configuration menu. No CAN. Has the menu been moved or changed. Or if the 2018 RoboRio reimage tool killing our CAN menu. Any ideas or solutions are helpful.

Thanks in advance,
5611 Neon Tigers

We ran into this issue as well. See the note on this page about installing the CTRE Phoenix framework to get the CAN web dashboard plugin to work:

The CAN Webdashboard plugin is no longer included in the base roboRIO image. To enable CAN device functionality in the roboRIO WebDashboard (and proceed with this article) you must now install the plugin using CTRE’s Phoenix Lifeboat. Instructions can be found on the CTRE Phoenix Wiki.

Make sure you upgraded your roborio’s web interface as described by section 5 of this document: By default the roborio cannot see the can network, and must be upgraded using the CTRE Toolsuite

Thank you for you speedy reply. I will try and then state if it worked or not.

One easy way to tell if this is the issue at a glance is if there is a CAN interface in the web interface list (even if there are no devices listed under it). If there isn’t, then the framework needs to be installed/updated to enable CAN support.

I had to install the Framework. Thank you!!