Can only connect to new radio after connecting over usb

Hello, I have been having some trouble with the new radio. I have an issue where the robot can only connect over wifi after we connect and disconnect over WiFi. When I turn it on with the Ethernet cable plugged into the closest connector (to the power). It connects for a seconds, then disconnects.

I have:

  • Downloaded the new radio configuration utility and re-configured the radio.
  • Used both ports trying the connect.
  • Re-powering the radio after it tries to connect.

The old radio works fine. Has anyone else run into this issue?

We always have to ask if you are cabled to the appropriate power. This radio is different than DLink.

We were having those type of issues then we updated the firmware through the configure utility and haven’t had any since.

It is hooked up to the 12V/2A connector on the VRM.

EDIT: I’ll try and update the firmware.

Have you tried hitting the reset button on the RoboRio after the Radio has powered up?

I hit the reset button after the radio power turned on and it worked. Is there a way to not have to reset it? That is sort of inconvenient every time we boot the robot?

Please try connecting the roboRIO and radio using the ethernet port next to the power connector.

Greg McKaskle

I updated to the latest DriverStation software and the problem seemed to go away. Thanks for all the help!