Cannot Boot From Classmate 2011 USB Drive to Image

I am unable to boot our 2010 Classmate off of the flash drive labeled “2011 Image for '10 Classmate” from the KOP.

Current Process to arrive at error:
Attach usb drive to USB port
Turn on Classmate
Press F11 to get boot menu
Select “USB: USB DISK”
System displays “Press ESC to Boot” with a countdown timer

Letting the timer go to zero results in the Classmate using the next available boot option (Booting to the HDD). Press “ESC” Does the same.

Troubleshooting Steps Tried:
I am able to boot off of the 2010 USB drive. The imaging software loads OK.
Tried both USB ports on the classmate
I am able to open and view the contents of the USB Drive.

The only thing I’ve noticed is when I put in the 2010 USB device I get the following options at the “please select a device” boot screen:

HDD: PM-SanDisk pSSD 16GB
USB:SanDisk U3 Cruzer Micro 8.0
USB:SanDisk U3 Cruzer Micro 8.0
USB:Generic- Multi-Card
Network: Realtek Boot Agent

but when I put in the 2011 USB device I get:

“HDD: PM-SanDisk pSSD 16GB”
USB:Generic- Multi-Card
Network: Realtek Boot Agent

What shows up in your “Please select boot device” screen when you put your 2011 image for '10 classmate" USB drive into your 2010 Classmate?

If there’s a utility to reimage your flashdrive I dont know where it is or which company is creating and maintaining these images for FIRST.

My guess is I will be reporting the USB device as “damaged” according to the KOP return instructions.


Posting this in case anyone else comes looking for a solution.

MBR of the USB stick must of been screwy. Used the following steps to workaround.

Using Shadowprotect imaging software I copied the disc image of the 2010 usb drive to another usb drive (including mbr). Deleted all 2010 files from this new usb drive. Copied the files from the 2011 drive to the new usb drive. Booted from new usb drive and completed “How to Setup your 2011 driver station” procedure.

Our team can’t do it either. I looked on this disk, and there were only 2 files under System Information (a standard boot disk directory), but nothing else. There’s supposed to be an entire bootable file system on there. Is there anywhere we can download the image (expecting the answer to be ‘no’ due to Microsoft licensing, but thought I’d ask anyway).

Please verify these things:

  1. On the root of the flash drive, “F:” assuming the drive letter is F:, there will be a file INSTALL.wim. IIRC it should be at least 1.5gb.
  2. In the “sources” directory there will be a file BOOT.wim it should be somewhere between 200mb to 500mb

If both of these are true for your drive please continue. Otherwise post your issue.

Option 1: Attempt a minor repair, which may be the root issue

Before continuing remove all other flash drives from the computer.

  • Open the command prompt on a Windows Vista/7 computer by pressing Windows Key+R, typing “cmd”, and clicking ok.
  • Type “diskpart” and press enter. Type “list disk”, press enter. There will be a list of drives attached to your computer. Find the one which has the same size as the flash drive, remember the drive number listed to the left of this size.
  • Type “select disk [NUMBER]” where [NUMBER] is the disk number identified above, press enter.
  • Type “list partition”, press enter. There should only be one partiton listed, if not STOP NOW, and verify what you have done so far!
  • Type “select partition 1”, press enter.
  • Type “active”, press enter.
  • Type “exit”, press enter.

Option 2: Use different boot media
You will need a Windows 7/Vista DVD to complete this option, but we will put the FIRST image on the classmate.

  • Boot from the Windows Install DVD.
  • Select default options until you get to the page which has the big “Install Now” button. DO NOT CLICK IT!
  • In the lower left corner of this page there is a link which says “Repair my computer”. Click it.
  • After a moment there will be a window with several repair options, select Command Prompt.
  • Plug in your FIRST imaging flash drive.
  • In the command prompt window type “notepad”, and press enter.
  • Select File>Open, and verify your FIRST flash drive is deteced. Remember what drive letter it appears as. Close notepad.
  • Type “cd [DRIVELETTER]” where [DRIVELETTER] is the drive letter of your flash drive.
  • Type AutoInstall, press enter.
  • The imaging will begin, and proceed as intended.
  • Reboot the Classmate.

If neither of these options work, please post what error message you receive.

Thank you EHaskins, but that’s really not the problem. The issue is that the disk was mostly blank, it only had a couple of files on it (I verified this on both Windows and Linux with a couple different messages, there was a lot of free space on the disk), and there was not enough information to boot or install with.

I think my team is going to borrow the disk from one of the other teams in the area and install from that. There has to be a better way to do this than rewritable flash drives next year…