Cannot change ds team number

We are have trouble changing our team number on the driver station.
We have the firmware updated. When we hold the down button nothing happens. What do we do?

We have tried with enabled/disabled, tele/auto, everything disconnected, everything connected, and with the laptop connected, but we still cannot get it to work. Is there some sort of combination we could be missing?

Update, our driver station suddenly worked (we did nothing to it) and allowed us to change the the number on the 40th something try

Any hints as to how you had it setup would be appreciated. I’m having this exact same problem with my DS.

[edit] After reading this helpful thread I did what I should have done.

We had done that. Ours just wouldn’t work until the 40th-something try. (We had given up on new ideas by that point)

Now it works fine. Great device right?

Once we had a firmware without the OTB on the screen everything worked first time.

Sounds like a same symptoms different cause thing.