Cannot Connect to Target while deploying.

Hey guys, we can’t for the life of us figure out why LabView keeps giving us an error every time we try to run as startup or deploy. It tells us that it failed to connect to the target. We’ve tried wiring straight into the rio via Ethernet and going through the d-link. We’ve formatted the rio successfully. Can someone help shed some light on this?

It is hard to know what the problem could be with your robot. But if you are connected via wifi or ethernet with the robot does not automatically mean that you can deploy code on it. Be sure to set the ip of the target right. In our case the problem was that the target was not selected right.

Go to your project explorer, right click on Target and select properties, then type in the right DNS that you set up on the roborio. in most cases it should be roboRIO-0000.local but your team number instead of 0000. This helped us.

Can you view the http://roboRIO-3350.local web dashboard?

Do things work as they should if you connect to the roboRIO via USB?

(Since the OP stopped posting, I’m hijacking this thread.)

I’m having this same issue, whether I connect directly via ethernet, USB, or via wifi. I can pull up the web dashboard with Internet Explorer (with Silverlight), and it confirms that we are using current firmware (3.0.0f0) and image (2016v19). DS gives me a green light for communication, but LabView can’t deploy any code, because it reports “Failed to connect to target”.

Any help would be appreciated. If we don’t figure this out, we have to use last year’s RIO, and we will have no working sister bot to work with after bag and tag. Thanks.

Double check your target name is roboRIO-5141-FRC.local

LV target.jpg

LV target.jpg

Thanks for the reply! I will check that this afternoon.

I’m doubtful that it’s pointing to the wrong target, because we’re able to deploy onto the old RIO just fine, and it has the same firmware and image. I don’t see why the target would be different on the new RIO…

I’ll check it though. Thanks again.

Following the other advice, can you use IE to see the roboRIO browsing to roborio-TEAM-FRC.local ? If so, navigate to the network adapter page and see what IP is on the roboRIO you’re having issues with.

Are you connected by USB or Ethernet/WiFi?

Thanks, Mark. Thanks, Jeff. That worked! We had the target set for the wrong IP. It’s working now!

Today we’ll try changing the IP on the old roboRIO to roborio-5141-FRC.local so that we know it’s following protocol for the competition. (I’m not sure if there’s a rule about this or not.)

We’re having trouble deploying code to the roboRIO–we’ve tried reimaging, we’ve made sure the firmware is current, and it still gives the “connection failed” error every time we try to Run As Startup.

We’ve tried using four different cables, two different computers, two different robot programs, and two different roboRIOs.

I’ve double- and triple-checked to makes sure that our target is roboRIO-876-FRC.local. Are there any other potential solutions? Has the correct formatting for target names changed with Labview 2017, maybe?

Assuming you are using ethernet or wifi the address of the roboRIO is still roboRIO-TEAM-FRC.local

Have you tried going to http://roboRIO-876-FRC.local using internet explorer (chrome may not work as this site requires Microsoft Silverlight)?

Can the Driver Station connect from your programming computer? To do this all other Driver Stations connected to the robot network should be off.

If the Driver Station program connects to the roboRIO and you can see the Web Dashboard of the roboRIO using internet explorer, the below items will probably not help.

Have you tried disabling all your network connections except for the one you are using? By this I mean right clicking the network connections you are not using in control panel and selecting Disable.

Your computer should use an automatic IP address since 2015.

If you are connecting though the radio, the radio should be updated with this year’s firmware and configured.

Try pressing the Reset button on the roboRIO to reboot it once everything else is on.