Cannot deploy code via Ethernet cable

This is an issue specifically for our programming laptop—what we were told at comp was that the version (Windows 11 before we reverted to 10) was incompatible. The driver station computer works fine deploying code using the same Ethernet cable (as it was already Windows 10.) However, even with the version change on the programming laptop, we still can’t connect.

Some background:
-We have a stable connection to the static IPv4 on the radio and can connect to the roboRIO config on the web browser
-We tried connecting to the USB cable and to the roboRIO’s direct Ethernet outlet, all to no avail
-All of our firewalls are disabled
-Checking on the computer’s terminal reveals that there is indeed a static connection going to the computer
-Reimaging and configuring the RIO has no effect on this laptop—multiple CSAs have tried this already

Any help is greatly appreciated, this process has been incredibly tiresome lol

What happens when you try and deploy? Does the build fail due to rio connection, or does Wpilib say that the build went through?

Does driver station show comms? If so, could you post a picture of the connections tab within driver station?

1 Like

To add, a snippet of the output log from the deploy would be very handy :slight_smile:

DId you try to Disable the wifi adapter on the programming laptop? We find that just turning off wifi is not sufficient.

Are you connecting to the radios “other port” or a switch?

I would suggest using a USB Type B cable and connecting to the Rio that way. That has always been a dependable way for us.

This is a dependable way to deploy, yes, however if some teams want to check their cameras before a match at a competition, you would need to be tethered via ethernet.

1 Like

Strange…I slept on it and now it executes the code when tethered, meaning it can be enabled. However, it remains on 80% while executing and won’t change past that. We reset the RIO and it didn’t have code on it but now shows green in comms, meaning it is being sent. Here’s a photo for reference:


I’m assuming your code works just fine over wifi, and builds with no errors.

Is your vscode Wpilib updated? Is your rio updated? Is your radio flashed?

What happens when you try and deploy a blank wpilib project? If you create a blank project and try to deploy, it will at least tell us whether it is something in your code, or something on the rio.

Last think I would try would be to uninstall and reinstall wpilib on your laptop - both the extension and the other tools it downloads with it.

Side note, while you have driver station up: could you post an image of the connections tab?
It is the second block on the left side of driver station.

Should look similar to this.

Are you using the User button on the roborio to do anything? Something new this year that was just found out a week or 2 ago is that holding the user button for 5 seconds can cause the robot program to not boot, and to hang at that step during the deploy.

You can hold the user button for another 5 seconds and reboot it to get out of that state. Would definitely recommend not using the user button for anything.

2 Likes

It’s very fickle now, so it may be an issue with the ports on the hub or an Ethernet possibly. I reset the RIO after it stopped connecting when changing the battery out, and now the build is successful with the Ethernet. I realize there’s a version issue with the driver station so I’m trying to update it currently, but here’s a photo nonetheless:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.