Cannot download files into the cRio

First of all i would like to state that we are a rookie team. We have a problem that we cannot seem to solve so I’d like to know if you could help us.
The problem is that every time we try to download any program into the cRio we get a message that says “Failed to connect to Real-time target”.
I would like to know if any of you has had this trouble before.

Several possible causes:

  • Make sure your laptop has a correct matching IP address on the NIC you are using, e.g., 10.xx.yy.6 It must be compatible to talk to the cRIO.
  • Has the cRIO been imaged (that’s when it gets it’s proper IP address)?
    *]Can your cRIO Imaging Tool see the cRIO? What IP address does it report?

Also make sure you set the IP address in your LabVIEW project.

We tried to follow everything according to the maunals for help but some were outdated.
The ip we are using is 10.xx.yy.2 according to what we have found we replaced the xs and ys with our team numbers and we left the 2 as it was.
The cRio imaging tool displays the same ip connection as the one we set in the labview project.

I dont know if I made myself clear

Did you disable any extra network adapters in the laptop? For example turn off wireless while you are trying to get it to connect with a cable. If you have successfully imaged the cRIO, try to ping it from a command prompt

ping 10.xx.yy.2

are you using a router our just directly connected to the cRIO? cross over or regular cable?
Have you tried using the driver station? what are the status lights in the diagnostic tab?

Read this, it is very helpful for getting things up and running…