Cannot get SmartDashboard to run with Simulator but Shuffleboard does

I can launch Simulator and then Shuffleboard and I can see the SmartDashboard.getxxx stuff, LiveWindow and FMSInfo. However, can’t get anything on SmartDashboard, even Connection shows Red.

Any thoughts?

Jim

1 Like

I’m running VS Code. There is no WPILib Simulator with SDB. I’ve been launching SDB from the desktop icon which is linked to a VBS.

I tried to launch from the terminal and it can’t find it. I openned a cmd window cd’ed to tool directory and launched it there with the -ip localhost. Same result. Wierd part is Shuffleboard works just fine.

As long as Shuffleboard works I can keep on training and I’ll keep trying shtuff. :smile:

Thanks.

Did you launch the vbs from cmd, or the smartdashboard jar?

Not sure what your suggesting. Here’s what I tried.

I launch it from a Windows cmd prompt.
image

And here’s SDB & Shbd

Just not sure. Thanks.

You’d need to type

frcvars2020

And then type

java -jar smartdashboard.jar -ip 127.0.0.1

Additionally, for the 2021 season we added it so you can specify an IP instead of a team number in the smartdashboard settings.

1 Like

I’ll take your word on that but here’s my results. :sweat_smile:

Like I mentioned, not a big deal as long as Shuffleboard is working. Might be something I’ve loaded on my machine. More curiosity then anything.

Thanks,

Sorry you need to be in the tools directory. C:/users/public/WPILib/2020/tools

HEEEYYY!!! :smile: :star_struck: :crazy_face:

lol. Thanks. Owe you one!

I tried to write a quick batch file (showing my age) in MyRobot project folder but it didn’t like frcvars2020 but it was OK with:
java -jar C:\Users\Public\wpilib\2020\tools\smartdashboard.jar -ip 127.0.0.1

So, I have all my FRC projects in _FRC folder. I but added MySDB.bat file to it and just have to type:
frcvars2020
…\mysdb

All good. As long as I don’t close the cmd terminal I launched from all I need to do is up arrow enter to repeat the previous command.

Again thanks,

Cooking with gas!
image

Swear, last time. :grin:

I checked and found that C:\Users\Public\wpilib\2020\frccode was on the path. So I moved MySDB.bat to there. Good so far. Then I noted frcvars2020.bat was right there. I tried to call it from MySDB.bat again with no luck. SOOooo, I copied the shtuff from frcvars2020 into MySDB and now I just need to type MySDB in the cmd terminal. :+1:

Now if the noobs want to play with SmartDashbaord & Simulator They just need 1 file.