Cannot import into WPILib 2021 with Microsoft VS Code from 2020 Gradle project

After installing WPILib 2021.3.1 for FRC onto my Windows 10 computer, I cannot import my 2020 Infinite Recharge, Cradle project developed under IntelliJ into MS VS Code. I’ve tried using both the prompted import when I open the folder and using CTL+SHIFT+P and initiating manually. I’ve also reinstalled using administrative authority. I’ve also tried leaving everything as default from the prompted update and changing the directories and project name.

From the prompted import:
image
Selecting Yes


Either changing the Project Name or selecting Import Project results in the following, changed screen and import does nothing, no messages, no nothing!

Project imports aren’t in-place – it’ll generate a new project to the specified location and copy the code. Does it do that?

1 Like

Project imports from 2020 are broken in 2021.3.1 (see https://github.com/wpilibsuite/vscode-wpilib/issues/454). Workaround is to manually import the project per Importing a Gradle Project — FIRST Robotics Competition documentation

Thanks, that worked. :slight_smile:

After making the changes, the import prompt again appeared but only to update from the 2021.1.2 as directed in the workaround to the currently installed 2021.3.1. After answering Yes to the prompt, VS Code opened. Closing and then re-opening VS Code with the project solicited no prompts.