Cannot open Raspberry Pi web dashboard

We’ve just bought a new RPi 3 and a webcam to test the vision system on our practice robot, but the web dashboard of the Raspberry Pi can’t be opened. I’ve tried re-imaging the RPi, swapping ethernet ports but it’s not working. Any idea on how to fix this?

Swapping Ethernet ports? The Pi only has one Ethernet port. I’ll ask the silly question first, you are imaging with the FRCVision image correct? You didn’t give a lot of info, so I have a lot of questions to help narrow down the issue. What OS and browser are you using? Are you running on a machine with mDNS installed (e.g. iTunes or the Driver Station / LabView update)? Are you cabling Ethernet directly from the computer to the Pi, or hooking up both to a network with a DHCP server? Does “ping frcvision.local” return responses? What is the IP configuration on the computer for the Ethernet (“ipconfig /all”)? If you hook up a monitor and keyboard, does it show the RPi booting? If it boots, log in with username “pi” password “raspberry” and run “ifconfig -a” – is there an IP address for the Ethernet interface?

By “swapping ethernet ports” I meant on the radio. I’m using the same computer that was used to code the vision system on our comp bot, so I guess the problem is not on the pc.

I was able to access the dashboard from direct ethernet connection, but not when connected through the robot radio. I’ve tried configuring the static IP of the raspberry pi to 10.XX.XX.6 with a subnet mask of, but that makes the RPi inaccessible entirely, both through ethernet and radio.

For static I recommend an IP in the .10-.20 range and a netmask of How have you configured the radio (in particular, did you check the firewall enabled box)? Are there link lights when you connect the Pi? Does ifconfig -a on the Pi report that the Ethernet link is active? Can you ping anything from the Pi (eg ping the roborio address)? What IP address is your computer getting? Is the computer connected via WiFi or Ethernet?

Thanks, changing the subnet to worked. I was actually following the IP networking guide on screensteps which said:

Other devices - Static 10.TE.AM.6-.10 or .12-.19 (.11 if camera not present) subnet

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.