Can't access cRIO module 2

We have a cRIO module in slot 2 that connects to our digital side car, which connects to our victors. I have simple code that creates a Victor object and sets it to new Victor(2, 2) for slot 2 and channel 2, and just does .set(0.25). Yet nothing happens, and the Victor continues to blink. When we try to run it we get an error that it can’t access module 2. Yet when I go into the cRIO imaging tool it is identified and OK. We so far have replaced the module, the sidecar, and the victors, with no avail. My future plan is to replace the battery, and the cable connecting between module and digital sidecar.

Has anyone else had an issue like this? Any fixes/advice?

EDIT: Alright, after a bit of research I found that one must do new Victor(1, 2) to access slot 2 on the cRIO. I’ll try that next time I’m there, but I also tried new Victor(2) with no luck. Isn’t that the same thing as new Victor(1, 2)? The only difference from new Victor(2, 2) is that it doesn’t complain about there being no module.

The first slot is “Slot 0”, the next is Slot 1, and so on.

Thank you. Before, I tried just new Victor(2). Should that have worked? Unfortunately it did not when I tried it, the Victor continued blinking. Is there anything else I should check? I’m gonna try replacing the battery and module sidecar cord next meeting.

Problem fixed. The PWM cable was possibly bad. But the real problem was that the digital sidecar wasn’t being powered properly.