Can't configure or load firmware to new radio

Hey guys,

We are having trouble loading firmware to and configuring our new radio. We tried it on our 2019 radio, and everything worked perfectly, but we keep erroring with the new radio.

From what we have discovered, we can’t get a steady blue power light, and the computer is sending information to the radio, but the radio isn’t receiving anything, so it looks like we’ve only got one-way communication. We can start the process of loading firmware, but it gives an error message saying the program timed out waiting for the radio.

Whatever we were doing worked on our 2019 radio, but for some reason, we just keep getting error messages when we try to use our 2020 radio. Is anyone else having this problem? if so, do you know how to fix it? We have competition in a week, so right now we are just planning on using our old radio, but we really want to get this problem fixed asap.

A couple things to try:

  1. Use a different computer to flash the radio.
  2. Try a couple different Ethernet cables – try to use a really good cable.

Also bypass the POE cable (use the regular radio power cable). We had the same problem until we did this.

Just to confirm, you’re waiting for the radio to be fully booted (approximately 45 seconds) before starting the process, right? The power light should start on-solid, turn off, come back on and flash, then go on-solid again.

We’ve waited for about 2 minutes and the radio light continues to flash.

Check if it’s broadcasting any networks. Might be something like qca_2g_test. I had one that behaved like that. Let me check with the one that actually got it working on specifically what he did. I think he just kept trying over and over until it finally took.