can't connect jags to bdc-comm

This is our first year using CAN, and the Jaguar Getting Started Guide says I need to update the firmware before I can use CAN. We have two grey and two black jaguars.
I plugged the CAN terminator into the right NET port on a black jaguar, then connected the left port to the CAN-Serial adapter I made with instructions from the Getting Started Guide. That adapted is plugged into a serial-USB adapter since none of the computers at my school have serial ports. When I run BDC-COMM, I see the attached screenshot. The Jaguar light keeps slowly flashing yellow. Any help? This is my first time using CAN, so any obvious fixes would be helpful too :smiley:



Looks fine to me. Have you tried flashing the firmware? You’ll find it in the File menu.

I can’t because the Jaguars aren’t connected. The light still flashes yellow, and if I try to download the firmware, it says it can’t contact the boot loader. The issue is that the Jaguar isn’t connected at all.

Have you tested all the Com ports, one after another?

A USB-serial converter will be a different port based on which USB port it gets plugged into and assigned.

The only COM ports were 1 and 3 (I always had the same USB port connected), and most of the controls were disable when I selected port 1. When I disconnect the serial-USB adapter, I noticed that COM port 1 stays on the list. It seems like BDC-COMM thinks there is another COM port on the computer, but I looked all over it and couldn’t find one. When the USB cable is plugged in and I select COM port 3, everything is enabled, but the Jaguar still won’t connect.

In addition to the previous posts, I recommend that you double check the adapter you made to make sure the RX and TX lines are connected properly. Also confirm that your 6p6c cable going from the adapter to the Black Jag is “reversed,” meaning pin 1 -> pin 1, pin 2 -> pin 2, and so on. See the Getting Started Guide for a good diagram.

Next I would try to reset the Jaguar to factory defaults by powering up while holding the user button with a paperclip. You can release it as the Jaguar flashes a slow green/red.


Here’s what I’m confused about. The CAN cables only have wires on pins 2-5, but according to the Getting Started Guide, TX is 1 and RX is 6. The CAN-serial adapter I have has 6 pins, but the CAN cables only have 4. Is this the issue? Do I need a special CAN cable between the serial and the first Jaguar that uses all 6 pins?

You at least need a cable with the outer two pins and a ground, and the easiest way to get that is to use a six-conductor cable. It likely won’t be labeled as a CAN cable, though, as CAN is usually just 4 conductors in the middle of a 6-pin connector. Not connecting those outer two wires would definitely keep you from communicating with the Jaguar over a serial connection.

Yes, I think that’s the problem. We just need a 6p6c to connect serial to the first Jaguar.

Yes, 6p6c is required between the serial adapter and the first Black Jag. After that it can be either 6p6c or 6p4c.

My team uses all 6p6c so that every cable is interchangeable and so we don’t have to buy two different sets of cable and connectors.