Can't connect to D-Link

Hello Everyone.
Mi team is having trouble connecting with the D-Link via the Bridge Configuration Utility. When launching the application, the network interface pop-up appears without any options, even when connected via Ethernet cable.
Does anyone know what the problem might be?
We are a bit desperate; we haven’t been able to connect to the robot. FYI we are newbies. :yikes:
Thanks for the help.

You’re using a Mexico-localized version of Windows, aren’t you?

Some of the configuration tools get confused when the information they’re trying to parse out of Windows doesn’t match what they expect. If you have a US-English Windows system, try it instead. If you can’t do that, there are manual configuration instructions around somewhere.

Does it look something like this?

Yes, it does. We have already tried connecting it via Ethernet Cable and pressing the Refresh button to no avail.

Could you please post the output of ipconfig?

Also, try this procedure for setting it up manually.

Open your Network and Sharing Center by hovering your cursor over the wireless icon on the toolbar or going through Control Panel.
Then go to Change Adaptor Settings in the left column.

That will give you a list of your active network ports.
Make sure they are Enabled (or right-click on each and choose Enable).

All our network ports are enabled, and still we are unable to complete the configuration through the FRC BCU. We have all deployed some code directly to the roboRio but are still unable to connect via wireless.

Have you followed the advice in the first reply yet?

We have tried what Alan Anderson says and it worked. The only problem now is that but it now displays an error when it is trying to locate the bridge at expected IP. We have already tried the solutions listed in the pop-up, but the issue remains. Could someone please tell us what we have got to do?

You have to tell us what the error says in order for us to know what is not working. Show us a picture if possible.

Here is a screenshot

Is the mode switch on your D-Link truly set to AP 2.4 GHz?

Is the D-Link actually connected to your computer using an Ethernet cable?

Are the power and AP lights on the D-Link indeed lit blue?

Have you disabled all network adapters on the computer except for the one where the D-Link is connected?

Did you try resetting the D-Link to its factory settings (a ten-second reset on powerup) before running the configuration utility?

Yes, Mr. Anderson. The D-Link s¡is set to AP 2.4 GHz, its connection to the computer is with an Ethernet cable, we have disabled all network adapters except for the one where the D-Link is connected and we did try resetting the D-Link to its factory settings. We have no idea why this error could be happening.

Perhaps your D-Link is just broken. :confused:

I can think of one further thing to investigate. Please open a command window and run the “ipconfig” command. Copy the output here. Maybe one of us will see something helpful.

Here is what it displays when we do that.

From that ipconfig it appears that your wireless is Disabled (or non-existent) since there is no entry for it.

It also has an odd IP address ( for the Ethernet port.
Is the laptop Ethernet port connected to a building network or to the robot’s DLink?

To connect via Ethernet to the DLink try this:

  1. Connect the laptop to the DLink via Ethernet cable
  2. Change your laptop’s Ethernet port IP address to
  3. Power up the DLink
  4. Set the switch on the DLink back to 2.4GHz
  5. Use a paperclip or other small pointy object to press and hold the rest button on the back of the DLink for a slow count of 10
  6. Wait for the two status lights on the front of the DLink to turn blue
    *]Try browsing to and see if you get the DLink login page
    If you can get that to connect, then we’ll go from there.

Mr. Anderson, we have succeed…partially. We were using a Virtual Machine, now changed a computer and it worked. The problem we currently have is that we can deploy the code into the robot, but unless it is connected with the cable the “Communications” and the “Robot Code” are lit red.

Is your computer still set to that unexpected IP address, or is it now configured properly for DHCP?

Can you ping roboRIO-5750.local? Do you get the web interface when you point a browser at http://roboRIO-5750.local?