Can't connect to our Robot, Driver Station's communication bar is half-full

  • Our RoboRIO, and our computers have the latest image/software update
  • We used different computers
  • We have never had this problem before until we downloaded the 2023 FRC game tools, previous versions worked perfectly.

When we launch the Driver Station, the communications bar only goes halfway, then the app freezes, we can’t click on any of the other tabs in Driver Station. Closing the application via Alt+F4 or clicking the ‘X’ button does nothing, we had to kill the application in task manager.

Re-opening does nothing either, upon re-launching the Driver Station it just repeats the same error.

The only error that is displayed says something along the lines of “Robot cannot communicate with the computer, check diagnostic tab for more information” however there is absolutely nothing in the diagnostics tab.

Is there any firewall enabled on your laptop?
Also, maybe redeploy the code? Sometimes, the communication bar being half full means no robot code running. Are any of the status lights on the RoboRio or radio blinking abnormally?

sorry for the late reply, but there were no abnormal lights on any of our components connected to the robot, our firewalls are disabled on all of our computers, and redeploying does not fix this issue, sometimes the redeployment fails and returns the “discoverroborio” error.

Can you post a screenshot of the driver station open to the diagnostics tab?

unfortunately I can’t do this right now because our shop is closed for the day, but I’ll get back to you tommorow

The half red/half green Communications bar isn’t a problem, it’s just information.
The green side is indicating that UDP traffic (how command packets are sent) is working from the roboRIO.
The red half is indicating there is no TCP traffic, which we don’t really care about unless your code has set up some personal TCP communications.

How similar were the different computers you tried?
e.g., are they school administered computers or personal ones?

1 Like

The computers we used are from the NYCDOE, but we erased everything from the computers, then we re-installed Windows 10 on it. So, there are no firewalls, restrictions, or any DOE software on the systems.

“Firewall (Dom, Pub, Pvt)”

Thats likely your problem right there. Disable your windows firewall

Hmmmm… our firewalls on both computers were disabled, but re-enabling the firewalls doesn’t help either.

Re-enabling is the opposite of what you want to do. Can you show a screenshot of your firewall being disabled? The DS seems to think its still enabled, so if it is truly disabled, then something else is in the way (anti-virus, vpn, etc)

Here is the firewall setings in Windows 10

We do not use any VPN’s or anti-virus programs on any of our computers

So i ended up using one of our desktop computers in our room, I had to install the FRC Game tools, WPILib, vscode, etc.

I was able to connect to our robot, both on code deployment and on Driver Station. This confused me because the computer had a firewall that was controlled by the school (via Symantec), despite this, I could get full communication with the robot.

I’m still confused as to what the problem with the other computers we had were, I presume that it had to do with some Windows setting that I don’t remember modifying or some program interference.

So i ended up taking the ‘nuclear’ option, and re-installing Windows 10 on our laptops, and all of the software we had on there. This took us about an hour but after this, we tried connecting to our robot… and it worked!

There was no half-comms bar, no failed code deployment, no tinkering with Windows settings either.