Can't connect to Photonvision through robot

We have photonvision running on Windows on the Beelink PC. We plan to update to Ubuntu later, but wanted to get the Windows version working. We can connect to Photonvision.localhost:5800 when running directly in the Beelink; however, when we connect the Beelink PC to the robot we cannot access Photonvision.local:5800 (we also tried photonvision.localhost:5800 when connected to the robot just to be sure, but it didn’t change anything). We either get a DNS error or a cannot be reached error.

We are connected to the FRC radio wirelessly. We are connected through a switch, but we can navigate to our Rio from our laptop so we feel the network is working correctly. We have also tried connecting the laptop directly to the network switch via ethernet, but that has not worked either.

Have you tried using the IP of Beelink PC to bring up the photonvision rather than the DNS name? (?.?.?.?:5800)

I don’t know what the IP is. We can’t set a static IP for the Beelink through Photonvision until we can connect to it on the robot.

Can youSet the windows ip in the beelink to fit your IP schema for your robot then try it.

I haven’t tried that. We may give that a shot. It just seems like something else is wrong that is keeping it from working properly.

We tried connecting to the coprocessor again, and got this message. Any help is appreciated.

1 Like

Have you tried using Angry IP scanner to find the IP address? Networking Troubleshooting - PhotonVision Docs. In my personal experience, this works really well.

Oddly enough sometimes connecting and turning it on through the labview dashboard in frc game tools has helped us identify which ip the subnet has assigned when using a radio ( are you using one ? ). I believe there’s usually a specific range recommended for cameras .

I have not tried that, I will do that this morning.

Yes, we are using a radio. We haven’t tried it through the dashboard though.

Use netplan on ubuntu to set a static IP address on the Beelink. Worked for my team. Let me know if you’d like more details

Which version of Ubuntu are you using? More details would be great

Ran AngryIP and didn’t find any IP with port 5800. The only IP that showed a port was for the Rio. It did find an IP that says it is a desktop PC, which I assume is the Beelink; however, when I ping it the request times out, and I cannot navigate to the IP in a browser.
I tried a different ethernet cable, and also tried connecting the Beelink directly to the radio’s 2nd port, but neither of those changed anything.

Edited to add:
I tried doing a remote desktop connection to the PC that AngryIp found and didn’t have any luck.

Update:
Our IT guy came in and we finally got the photonvision to connect through the robot; however, now we cannot set a static IP address. We go to the network settings as instructed, but there is not an option to select staticIP.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.